Asus P8Z77-V LK won't see SSD on SATA 3

I'm using an Asus P8Z77-V LK mobo and a Samsung 830 ssd and the ssd only shows up in BIOS when I plug it in to a SATA 2 port.

The SATA 3 ports work fine with the DVD drive.

I've tried updating the firmware and the bios to no avail.

AHCI is enabled, and as far as I can tell, all of the SATA ports on this board used Intel controllers.

Does anyone know of a reason this would be happening?
10 answers Last reply
More about asus p8z77 sata
  1. At least on my p8z77-v PRO there are 2 or 4 (can't remember) sata ports controlled by an ASMedia controller, which I believe has to be activated in the BIOS.
  2. I'm pretty sure the only controller I have is the Intel c216 SATA controller. It's listed as having 6 ports and thats how many I have on my mobo.
  3. HerrJordan - did you find a solution to this? I am encountering the same issue with same motherboard and samsung 840 pro. drive doesn't appear in bios when connected to sata 3 ports. sata 3 ports have been verfied, bios is current. no joy.
  4. having the same problem with intel 520 240gb

    could this be a problem with mobo?

    my ssd is fine on sata2
  5. anyone find a fix to this yet?

    i exchanged for a new mobo, same problem
  6. Have you tried different SATA cables (3.0 6GB/s) ?
    Something like http://www.newegg.com/Product/Product.aspx?Item=N82E16812123349
  7. i dont think its the cable, because the same cable works fine on the regular harddrive
  8. Maybe it is worth a try. They are not expensive.
  9. Sorry for reviving an old thread, but I had the exact same problem with a Samsung 840 SSD boot drive not being detected in BIOS when plugged into the P8Z77-LK's SATA 3 port. Worked fine when plugged into the blue SATA 2 port, but wasn't happy about the SATA 3 ports not working. As a last resort I re-attched the SSD to the SATA 3 port, then went into the BIOS and pressed F5 (Load Optimized Defaults). Saved. rebooted and voila, the computer booted from the SSD normally. So try loading optimized defaults and see if that fixes the issue.
  10. Thought I would bump this Thread as I too am having the exact same issue with the Mobo and a Sandisk Ultra II 960GB SSD!
    Blu-ray DVD burner works great and shows up in the bios on the Grey Sata III. Also, have a raid 1 mirror that works great on the SATA II (blue ports), along with the Sandisk also on SATA II blue ports.

    NO joy however with the Sandisk on the SATA III port, whether it be AHCI, IDE or RAID (which is the mode I use currently...). Won't even ID in the bios. I would VERY much like to get it working on the other GREY SATA III port and hope I can move it there without having to re-install!
Ask a new question

Read More

Asus SATA SSD Motherboards Product