GA-Z68XP-UD3P with 32GB RAM

Hello,

I just bought 32GB (4x8GB) Corsair Vengeance RAM to go in my custom build and noticed that my computer has virtually ground to a halt. At first I thought it was bad memory, but if I just put in 2 sticks then everything works fine. Then if I swap with the other 2 sticks, everything is still fine, it's just when I have all 4 sticks in that everything grinds to a halt.

Am I missing something obvious? I was hoping to have 32GB in for some VMs so I can learn some SharePoint development, but I'm not particularly happy that I can only use half the RAM I bought.

I have no idea what revision of the motherboard I'm running, nor do I know what version of the BIOS I've got (or if it's meant to make a difference).

Any suggestions would be welcome.

My build is:
i5 2500K
GA-Z68XP-UD3P
32GB Corsair Vengeance RAM
MSI GTX580
OCZ Vertex 3 120GB
Corsair 750W CMPSU-750TXV2 PSU
5 answers Last reply
More about z68xp ud3p 32gb
  1. Hi, I can't see a 32GB RAMs kit listed by Corsair as compatible with the board ( http://www2.corsair.com/configurator/product_results.aspx?sc=us&id=2094128 ).
    Do the 2 RAMs work in both channels?
    If yes, then it might be a compatibility issue. Have you tried clearing the CMOS, when filling all slots?
    Crucial does list a compatible kit: http://www.crucial.com/store/listparts.aspx?model=GA-Z68XP-UD3P&Cat=RAM
  2. OK, so I've tried using both channels (I think, since I'm quite new at this stuff). I tried putting a pair of simms into slots 1 & 3, and slots 2 & 4, and everything works fine.

    I then tried putting all 4 in, and choosing "Load Fail-Safe Settings" in my BIOS and it still was running badly. Just to clarify, it takes about 5 seconds to boot Windows 8 with the 2 simms, but about 3 minutes with the 4 simms.

    I'm guessing I might be stuck with the incompatible RAM :( This is the type I bought:
    http://www.scan.co.uk/products/32gb-(4x8gb)-corsair-ddr3-vengeance-lp-jet-black-pc3-12800-(1600)-non-ecc-unbuffered-cas-10-10-10-27

    Doesn't look like my supplier stocks the Crucial RAM, so I might be stuck the excess.
  3. Try contacting Corsair, see what they say.
  4. Thanks for your help.
  5. I managed to resolve the issue by updating the BIOS from my version (F2) up to the UeFI version. Fixed it perfectly and haven't had any troubles at all.
Ask a new question

Read More

Corsair RAM Memory