Asus P8Z77 V and G.SKILLS 16gb ram issues

My P8Z77 in my new built wont load the bios when i try to boot it up. The cpu led shine red for a split second and then turns off and the Dram MemOk! led shines red. I've tried every slot with 1 or 2 ram sticks in the slots and I can't seem to get it to go away. Do you think this problem is because of bad ram or a bad cpu? My ram is suppose to be compatible with my motherboard so I'm not sure whats happening. Any input is very appreciated.

Specs-
i7 3770k
gtx 680 classified
ASUS P8Z77-V LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
16 gb G.SKILLS Ram
hyper 212 cooler
750w corsair power supply
1 samsung 830 ssd
1tb seagate hhd
lite 0n optical drive
17 answers Last reply
More about asus p8z77 skills 16gb issues
  1. Try testing the board outside the case (to rule out a short). It might be a CPU socket bent pins issue.
  2. alexoiu said:
    Try testing the board outside the case (to rule out a short). It might be a CPU socket bent pins issue.

    I've taken out the cpu twice to check for bent pins and there aren't any as far as i can see. Is taking the motherboard and all the components out needed? It took me 6 1/2 hours to assemble..
  3. At least check if there is an extra standoff that might short the board.
  4. Everything runs except that the MemOk! led turns red, could it just be a ram issue?
  5. If the RAMs are compatible and you've tried each RAM stick, I doubt it's a RAMs compatibility issue. What's the RAMs model? Check on GSkill the compatibility list: http://www.gskill.com/configurator2.php?pid=2&model=1541
  6. This is what i bought from newegg.com- http://www.newegg.com/Product/Product.aspx?Item=N82E16820231606
    I believe this is the right one on the website - http://www.gskill.com/products.php?index=539
    It says is compatible with asus p8z77 v-deluxe, pro and premium but i don't see my mother board on the list?
    My motherboard- http://www.amazon.com/gp/product/B007G51UWY/ref=oh_details_o01_s02_i00
  7. Although not listed, it should work, IMO. Check though for an extra standoff. Cleaning the CMOS might also help. Make sure the module is properly inserted. I know it's difficult, but with the board outside, you have a better control regarding the components installation.
  8. I'll try doing that this weekend, really bummed out on how it hasn't booted up yet :|
  9. Seems my ram wasn't fully installed and needed to be pressed down harder :D saved me a lot of trouble shooting :) for installing drivers i only need the most recent versions right?
  10. Yes, install the most recent ones. If you get issues, then try the one on the motherboard's CD.
  11. It's taken a while to shutdown after installing 88 window updates, that's completely normal right?
  12. Yes, it's normal.
  13. Thanks for all the help, i really appreciate it!
  14. You're welcome. Good luck!
  15. its still shutting down after 6 hours.. should i manually shut it down?
  16. 6 hours? Yes, try manually shutting it down.
  17. did, every thing seems in order
Ask a new question

Read More

Memory RAM LED Monitor Product