Sign in with
Sign up | Sign in
Your question

GT 540M with Optimus failing. Please help.

Last response: in Graphics & Displays
Share
August 12, 2011 10:06:34 PM

Hi all

I'm facing this here odd problem on my new laptop. I have tried everything and desperately needs your help.

It's an ASUS X93SV (K93SV), I5-2410m, GT 540M 1GB, 8GB Ram, HM65 express chipset, Windows 7 64 bit Home Premium.

When I run 3dMark06, Dirt1, Dirt2, Dirt3, etc. I get too few FPS. The system seems to be using the Nvidia Card, but FPS's tells it doesn't happen.

From review of similar systems, I can see that with an I5-2410m - GT 540M laptop, you should get around 7.800 in 3dMark 06.
Link1 link2

But I'm getting around 4200
The built in demo in both Dirt 2 and Dirt 3 gives me around 12 fps (fairly independent on settings, even "Low") where reviews says much more frames
Link3

Intel Graphics driver version is: 8.15.10.2361
I have tried Nvidia drivers:
From Asus: 268.39
From Nvidia: 270.61, 275.33 and now also 280.26. All without working.

I have tried on automatic settings in Nvidia Control Panel -> Doesn't give correct FPS's
I have tried on setting Nvidia Processor for 3Dmark and Dirt -> Doesn't give correct FPS's
I have tried setting Nvidia Processor as Globally Preferred graphics processor -> Doesn't give correct FPS's.
And I have tried all the above Nvidia driver versions.

The very odd thing is, that I can get the notificiation icon for which graphics processor used, to show that it is using Nvidia (but with no extra FPS's). Also in the benchmark result folder for Dirt2 and 3, the "hardware_settings_info.xml" file says it runs the GT 540M. But again with very few FPS's.

So, the system seems to be responding that it uses the GT 540M card, but it actually doesn't.

- What the freak could be causing this problem??

I'm getting desperate.

The combination of motherboard, I5-2410M, GT 540M with Optimus have been working as you can see from the reviews.

I have seen a few discussion similar problems but not many. Could it be an Asus specific problem?

I think I have the Intel chipset drivers needed, but if someone could specify which ones are needed it would be nice.

Could it be Asus Bloatware that came with the laptop that mess the system up?

Please please help. I bought the rig also for gaming.

- - - -
From hardware_setings_info.xml from Dirt 3
<graphics_card rating="2" name="NVIDIA GeForce GT 540M" memory="4065" native_height="1080" native_width="1920" ps_shader="3_0" vs_shader="3_0" deviceId="0x0DF4" vendorId="0x10DE">

More about : 540m optimus failing

August 13, 2011 4:27:37 AM

Uninstall both drivers, then install the Intel ones first. After rebooting and all that jazz, install the nVidia drivers. Also, get the Intel drivers from the Asus page, not Intel's unless Asus tells you to do it. Same goes for nVidia.

The other thing that comes to mind is to watch out for the bloatware that came with the notebook, specially "ATK" from Asus. Do you have software running in the background when playing? Etc...

I just sold my Asus N53JF, but never run into this problem. It had a Core i3 + GT425M and played everything fine.

Hope it helps.

Cheers!
August 13, 2011 8:39:49 AM

I tried uninstalling both drivers, and install ASUS drivers, with Intel first, then Nvidia.

Regretably with no fix. I actually recall re-installing ATK drivers from ASUS. I try uninstalling them to see what happens. (But I belive I need them for FN-shortcuts to work... )
Related resources
August 13, 2011 11:32:11 AM

set power plan to PERFORMANCE
August 14, 2011 9:19:13 PM

I have set it to High Performance.
Via ASUS Power4Gear Hyrbrid
a b Î Nvidia
August 14, 2011 9:22:46 PM

My first thought that isn't enough for gaming at that ress with any playable fps but I am not surprised that there might be a software related issue. 1600x900 maybe but 1920x1080 no thanks as it takes a lot more than that to run with comfort. Dump some of the settings and overclock a little and go from there.
!