SATA III Not Working

Hey, I'm having some difficulty getting my new PC I've built to function when hooking the hard drive up to the SATA III connecter on the motherboard. Here are my system specs:

Motherboard - ASRock H61M/U3S3 Intel H61 Micro ATX DDR3 1333 Motherboard
CPU - Intel Core i3-2100 Processor 3.1GHz 3 MB Cache Socket LGA1155
RAM - Mushkin Silverline 4GB (2 x 2GB) 240-Pin DDR3 SDRAM
Hard Drive - WD Black 750 GB WD7502AAEX
Power Supply - OCZ ModXStream Pro 500W
Video Card - PNY XLR8 GTS 250 1024 MB VCGGTS2501XPB

So I put everything together, hooking the hard drive up to one of the SATAIII ports on the mobo. I went to do a fresh install on the hard drive with Windows 7 Home Premium, but the install kept hanging, usually during the completing install phase.

So after trying various things, I plugged the hard drive into one of the SATA II ports instead and tried again. Win7 installed no problem. So after installing windows updates, mobo drivers, etc, I tried switching the hard drive back over to the SATA III port to see if it would boot from there.

When I tried to boot into this configuration, I would get a blank black screen, except that my mouse pointer is on the screen and works. I then tried re-booting and was able to successfully boot into safe mode. This behavior is repeatable.

So I've been running for about a week now with the hard drive plugged into the SATA II port instead of the SATA III port. Haven't experienced any problems at all.

Would appreciate any suggestions on what I could try to get my hard drive working on the faster port.

Thanks for your Help
3 answers Last reply
More about sata working
  1. You have tried in multiple SATA III ports? Also I was checking out your board online... Can you maybe link me to the correct one? Cus unless I'm mistaken that board has 4x SATA 3gb/s ports (Blue) and 2x SATA 6gb/s ports (white)
  2. Here's the link to the motherboard.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16813157236&Tpk=ASRock%20H61M%2fU3S3

    Good idea on the other port, I only tried one of them. I'll give the other port a try.
  3. If plugging into a different sata 6 GB/s port doesn't work Then during OS installation when it asks you to pick a hard drive to install on you're supposed to click on the install drivers and install the sata 6 GB/s driver from the motherboard disk. It solved that same problem for me on a different motherboard. Go on Asrock's website to see which driver(s) should be pre-installed.
Ask a new question

Read More

Homebuilt SATA Hard Drives Motherboards Systems Product