Sign in with
Sign up | Sign in
Your question

MSI 990FX - No video, no post, no beeps.

Last response: in Motherboards
Share
November 10, 2012 5:02:10 PM

Got a new motherboard for my system, and after installing everything, I am getting no video at all, not even BIOS. Some other odd symptoms to note: My power button will turn the system on, but not off. The reset button doesn't work anymore either. The only way to turn off is to flip the PSU switch. I found another thread of someone having these exact symptoms, but their fix was that the 8-pin power was not properly inserted. Mine is. I'm getting no error beeps, even when booting without ram, though I could have a bum speaker. I realized I don't think I've ever heard that thing beep before.

Specs:
Motherboard: MSI 990FX
CPU: AMD Phenom II x4
RAM: Corsair 4GB x2 DDR3
GPU: GeForce GTS 450

This mobo has no onboard video, so I'm unable to check using just that. I've tried booting with no ram, 1 stick of ram, both sticks, have moved the GPU between PCI slots, rechecked all power cables (including the power and reset button wires), HDMI, DVI, everything I can think of. I've unplugged every other peripheral, including DVD drive and hard drives.

Is there a possibility broken/bent CPU pins could have a hand in this? I had the HARDEST time getting my CPU in this board. It slipped effortlessly into my old board, but refused to go in this one. I thought I got it in there without issue, but now I'm doubting myself. Checking that will be a last resort though. CPU and CPU heatsink installation is my LEAST favorite thing ever.

Thanks in advance for any help!
a c 559 V Motherboard
November 10, 2012 5:14:14 PM

I would take the board outside the case, leave only the CPU, CPU fan and speaker installed, remove the power, reset, hdd LED, recheck that the 24-pin and the ATX 12V are proerly connected and start the board by using a screwdriver for shortly connecting together the two pins corresponding to the power switch.
If still no beeps, then checking for bent pins would be th next step.
m
0
l
January 21, 2013 3:40:13 AM

Siesna,

I am experiencing the same things you are and have the same setup. I also replaced an old motherboard and had difficulty inserting the damn CPU.

Please let me know how you resolved your problem.

Thank you,

huntclan
m
0
l
Related resources
January 26, 2013 11:31:41 PM

Nothing on this??!! I am having the same issue with an Intel MSI board...
m
0
l
May 20, 2013 5:12:07 PM

Sorry I never replied back to this, guys. Unfortunately, I never got the mobo to work, just went back to my old one. I even bought a new CPU, and after finally forcing it into the board (hunclan, it is not just you! It is REALLY hard to get in there!) I still had no luck. Frustrated, I gave up on it, and it's sitting in a box. Wish I'd thought to return it to Amazon, but I it's too late now.
m
0
l
May 20, 2013 5:56:16 PM

I RMA'd back to MSI. They sent a new one that fixed the problem. They new one had a defective USB header, but I will live with it and not buy another MSI board again:( 
m
0
l
February 6, 2014 7:34:27 PM

Have You Guys tried flashing the bios? maybe initial Bios from Mobo do not support processor. u can take the Mobo to the specialized store where u bought it and ask if the store provides that service.

hope it works!
m
0
l
!