Closed Solved

8gb DDR3 RAM not posting

Hello,
I have an ASRock N68C-GS FX mobo that has both DDR2 and DDR3 supported (there are 2 slots for each RAM type). I can boot on 4 gb DDR2 ram, but when I put in my 8 GB DDR3, I cannot get it to post. The DDR3 is 2 4gb sticks, and the DDR2 is 2 2gb sticks. My OS is ubuntu 64 bit. Any help is appreciated
8 answers Last reply Best Answer
More about ddr3 posting
  1. yes, I am Removing Both DDR2 chips, and putting in 2 DDR3 chips
  2. That type of board supports either DDR2 or DDR3 but not both at once. To clarify, are you trying the DDR3 by itself and it won't work?
  3. Have you tried them one at a time, in each DDR3 slot?
  4. not yet. i'll try that and get back to you

    EDIT: I tried that, and it still did not post.
  5. I edited my post, and got no reply. Just letting you guys know because i was not sure editing counts as a reply :D
  6. Best answer
    I'm sorry to hear you still had a problem. It sounds like either bad RAM (both sticks) or a faulty motherboard. Did you check the BIOS, though? I'm assuming it will automatically detect the RAM type but maybe there's a setting in there you can check (using the DDR2 that boots, of course). If you're able to, try to test those DDR3 in another computer.

    But you might just get higher capacity DDR2 since you know that part works. There's a measurable performance difference but it's not huge.
  7. ok thanks for the help. ill see if i can't mess with the bios.
  8. Best answer selected by mryan2.
Ask a new question

Read More

ASRock DDR2 DDR3 RAM Motherboards