Sign in with
Sign up | Sign in
Your question

ASUS P8P67 BIOS - DISK NOT DETECTED

Last response: in Motherboards
Share
November 11, 2012 5:16:32 PM

My PC is a self build and has worked perfectly for 1 year. Yesterday my AVG antivirus ran an update and gave me a notification saying "To complete update, restart now or in 1 or 4 hrs". I hit "restart now". The shut down seemed tidy.

The ASUS screen came up, followed by a screen that said: HARD DISK NOT DETECTED (it did not say this before). This screen normally is followed by Windows 7 (64-bit) loading up, but this time it went to a blank screen (black) with a white cursor that kept on flashing and this is as far as it goes. If I switch the PC off/on manually, it does the same thing over.

After a number of attempts, I did a CMOS reset. I did the F2 to SET UP and it goes back to BIOS with the same result.

The system has a KINGSTON SSDNOW V100 as the primary drive and a Western Digital HDD as the secondary. When I go into BIOS, it shows both drives being present, so the BIOS does recognize it.

The other thing I did was to install my Windows 7 disk to see if I can repair the issue. It does not allow me to "repair Windows" (it says something about not being the right format). The other option is to do a clean install, which I think would work okay, but I want to save my data.

These are the questions I have to the above issue:

1) Is there a way I can get this issue fixed in a simple way (no clean install etc)

2) If have to do a clean install, then I will take the opportunity to buy a new SSD (Crucial M4) and use that as my primary drive. If this is the case, how do I go about recovering data from the KINGSTON SSD (I have all my data backed up on the HDD, except for the last 2 weeks. Ideally, it would be nice to recover the last 2 weeks data, if it is not going to cost me a few gold bars :)  )

Thanking you in advance for you help.
November 16, 2012 2:15:14 PM

I did a little research and found out that the Kingston SSDNOW V100 has a known issue of the drive failing. It happens sooner with most people, but I got lucky for a good 12 months or so.

I decided to upgrade my SSD, as they are so much cheaper now and i did not want a SSD that has known issues. I upgraded to an OCZ Vertex 4 and all seems to work fine. I guess that my issue WAS the Kingstone SSD.

I have not tried to retrieve my data from the old SSD nor have I contacted customer service yet. I will post the updates to those in due course. For now, I am glad that I am up and running.
!