Sign in with
Sign up | Sign in
Your question

Files becoming corrupt when being transferred

Last response: in Motherboards
Share
November 11, 2012 5:54:02 PM

I built a new computer a few months ago and have had a consistent problem with writing files from my computer to an external device such as a USB drive or a USB external harddrive (and I have tried "safely removing hardware"). At first I thought it was a problem with my USB on my motherboard, but I have exchanged my motherboard 3 times over the past month and have had the same problem on all of them. I have a 120 GB Corsair Force 3 SSD that I have windows 7 loaded on, and whenever I write files from my SSD to a USB drive, the file gets corrupted and usually I won't even be able to open it. However, yesterday I noticed that I was also getting corrupt files when I uploaded pictures to imgur. So I started playing around with transferring files and I uploaded files to imgur from my internal SSD, my internal HDD, my external HDD, and a flash drive and all the files were corrupted during the upload. I also transferred files across every combination of those (like from my external hdd to my flashdrive), and ran into corrupt files each time. Does anyone know why this would be happening? This is driving my crazy since I can't "productively" use my computer because I can't get any files off of it. My BIOS for my motherboard is up to date, and I have installed all the latest drivers as well as all the Windows 7 updates. I have also reformatted my computer 4 or 5 times to try and fix the problem. My specs are below. Thanks!

Windows 7 64 bit
ASRock Pro 3
i5-3570K
Corsair Force SSD 120GB Sata 3(Win7 installed on this drive)
G.Skill DDR3-2133
a c 162 V Motherboard
November 11, 2012 6:18:56 PM

Sounds like a Virus/worm to me.
November 11, 2012 6:33:40 PM

I'm running on a fresh install of Windows 7 right now. And I have reformatted a few times over the past month and the problem never went away.
Related resources
a c 162 V Motherboard
November 11, 2012 7:05:29 PM

simransingh2 said:
I'm running on a fresh install of Windows 7 right now. And I have reformatted a few times over the past month and the problem never went away.


Have you formatted all your externals as well??? Or atleast scanned them with MS security essentials after a fresh install?
November 13, 2012 4:02:31 AM

Yes. I just reformatted my SSD as well as a flash drive and tried transferring a picture across on a fresh install of win 7 and it got corrupted.

I thought it was my SSD, but I installed win7 on an internal HDD and had the same exact problem.
March 16, 2014 11:51:05 AM

This same problem has plagued me for months. FINALLY I figured out what the cause was, at least in my situation. Having my printer plugged into one of the USB ports at the same time of transferring photos from camera (or SD card in card reader) is what corrupted my images. When I unplugged my printer, everything worked fine. I could use my camera with USB cable or SD card plugged directly into the reader. I knew it wasn't a problem with the SD card, my camera or my camera's USB cable because the photos transferred fine on another computer. Try systematically disconnecting other USB devices to see if that might be the issue for you --- but do it systematically, just disconnect one device, then try the camera import, until you've tried all devices. Doing it one at a time helps you know which other device is causing the conflict (if any). In your case, it might be some other problem. Good luck.
!