570 sli dx11 problem crysis 2

Guys,

I just recently built my new system. Mainly for BF3 and recent games to keep me occupied. I'm currently playing Crysis 2 with Ultra setting, 1920X1080 Res, High Res Texture Pack, DX10 and I run at 60FPS all the time do to VSync. Flawless. Its great.

I just recently got the new DX11 Pack and my frames just dropped to 6-13 FPS. Purely unplayable. Something is very wrong. The min I start the game the intro screen is very laggy and the main title is also. Same FPS as in game. My GPU load is only at 1-3% at that time. In-game GPU load is at around 50-80%.

I tried lowering everything to Min with DX11 with High Tex off and made not 1 diff. I ran a few Nvidia Demos with Tessellation setting on max with Vsync and I ran those flawlessly. I went through diff drivers as well as reinstall Crysis2. Nothing...

Any ideas will be greatly appreciated.

System build is:

Corsair 800D Case
ASUS P8P67 Deluxe R3 LGA 1155 P67
Intel 2600k OC to (5.1Ghz)
Antec 920 Cooler
(1tb) Sata6 HD
EVGA GTX570 SLI
Vengence Corsair RAM (8Gb)
750wht Power (78amp)
7 answers Last reply
More about dx11 problem crysis
  1. Try the following, disable SLI and then try to execute and see if it works

    This thread is similar to yours
    http://www.overclock.net/pc-games/1052617-crysis-2-dx11-problem-2.html
  2. I believe that it is only the game and your system is very good compared to most. If any thing hardware related a slow drive could be holding you back but not enough for this so you are looking at software being the issue.
  3. BTW you never told us what resolution you play at and how many monitors you use.
  4. ps3hacker12 said:
    BTW you never told us what resolution you play at and how many monitors you use.



    Quote:
    Guys,

    I just recently built my new system. Mainly for BF3 and recent games to keep me occupied. I'm currently playing Crysis 2 with Ultra setting, 1920X1080 Res, High Res Texture Pack, DX10 and I run at 60FPS all the time do to VSync. Flawless. Its great.


    Yeah.. he did..
  5. Looking at your overclock, it's possible is causing problems. Have you tried backing it off to 4Ghz to see if anything changes?
  6. phishy714 said:
    Quote:
    Guys,

    I just recently built my new system. Mainly for BF3 and recent games to keep me occupied. I'm currently playing Crysis 2 with Ultra setting, 1920X1080 Res, High Res Texture Pack, DX10 and I run at 60FPS all the time do to VSync. Flawless. Its great.


    Yeah.. he did..


    i meant what resolution he was playing at on his second run through.
  7. Hey guys,

    Thanks for your replies. I tried disabling SLI and even disconnecting the second card altogether. Unfortunately nothing seems to be working. I also tried dumming the CPU to 4Ghz. Nothing so far.

    Not exactly sure what going on. I read people with 1 570 running fine with DX11 as well as 2. Not sure why I'm still have the same issue. Iv heard people having simular issues but not exactly as mine. I see everything fine when starting up the game but the FPS is nearly down to 5. Iv tried diff Resolutions but they all have the EXACT same FPS.

    I'm running only 1 monitor which is a 32" LG LED HD 1080P 2ms response. Bad Company 2 runs wonderful as well as all my other games. Just Crysis2 has an issue with DX11. But not DX10.
Ask a new question

Read More

Graphics Cards Games Crysis Graphics