Sign in with
Sign up | Sign in
Your question

Image Resolution and Scaling Problem with Intel Built-in Graphics

Last response: in Graphics & Displays
Share
August 15, 2011 5:38:33 PM

Hi,

I have an Intel Core i5 with built-in HD GMA Graphics and I run into a problem that is just really frustrating to solve.

I'm not a gamer and I mostly want to watch videos and DVDs out of my PC and I want to connect the computer to my Samsung 50" HDTV.

However, when I use the HDMI-to-HDMI cable, the picture that is shown on the HDTV is too big and it spills out of the border of the TV and I cannot see the edges of the monitor, including the BIOS setting page from the motherboard. Intel supports GMA drivers and graphics utility that can set the resolution to native 1280x720 and Windows 7 looks good and normal on TV. But it's just that I cannot play around with the motherboard BIOS to set up certain things that I wanted to do.

So I have another HDMI-to-DVI cable that came with an old DVD player and when I use this cable from HDMI output of my PC to the DVI input of the HDTV, the BIOS image and text comes out perfectly just like a PC. But when I go to Windows, the resolution for 1280x720 is cut off with black bars around the image, it's too small and it's not looking like a real full-screen HDTV. Using the Intel graphics utility, I can change the resolution to 1920x1080 and manually adjust the horizontal and vertical scaling to fit the length and width of the TV. But in doing so, the text quality is awful and too small. My HDTV supports both these resolutions.

So in short, HDMI-to-HDMI produces good pictures on Windows but scaling problem with native BIOS settings, HDMI-to-DVI produces normal image on BIOS but reduced resolution on Windows.

Questions:
1. From what I understand, HDMI and DVI have identical video data so why on earth the DVI and HDMI resolution can be so different on the same TV? What's going on?
2. Is this a hardware problem that is inherent to Intel GMA? I don't want to spend any money to buy a graphics card if I can.
3. Any suggestion how to fix this?

Thanks in advance.
a c 173 U Graphics card
August 15, 2011 6:06:46 PM

This is a common problem and have seen it my self so I know it to be a pain in the backside but never put any effort into solving it. Do you have a old graphics card on hand just to explore what options that you have?
m
0
l
August 16, 2011 1:18:48 AM

Unfortunately I don't have any graphics card with an HDMI output. So far the best setting I can find is to get my Samsung HDTV to use an "Extended" PC mode, which stretches the image, then use the Intel graphics utility to force scale it down in Windows 7. With this setting, the BIOS screen is squished and small but at least I can see all the text and can work with it.

Another problem that I forgot to mention is that I have Windows 7 - Linux dual boot and whatever fix I do for Windows just messes up Linux. Intel graphics utility is not supported in Linux so I cannot do anything with that.
m
0
l
Related resources
a c 173 U Graphics card
August 16, 2011 1:34:36 PM

Right now I am not liking Win7 my self but at least vista works like it should despite being bloated. As for linux what distro are you using?
m
0
l
August 23, 2011 12:35:57 AM

I kinda like Win7...

I installed Fedora and Linux Mint (but uninstalled Fedora) and they both have problems with graphics. Any idea what to look into to fix it?

Thanks.
m
0
l
a c 173 U Graphics card
August 23, 2011 1:15:54 AM

That is sad to see Mint having issues. I know Suse works on Intel GMA but I would not be surprised if the TV is in at some fault with this and the drivers. Not there is any thing wrong with it but they are usually problematic when it comes to using them as monitors. Some have great luck with them while others do not. Do you have a dvi to hdmi adapter and a old card?
m
0
l
a c 365 U Graphics card
a c 118 å Intel
August 23, 2011 1:17:26 AM

Try to see if your HDTV has an option that may correct the issue.

I had the same issue you currently have with the desktop being "too big" to fit on the screen when I hooked up my HTPC with a GeForce 9600GT via HDMI. In my LG 47LH90's Picture menu there is an option in the Aspect Ratio field for "Just Scan". This quickly fixed my issue.

Perhaps you can try out different options that controls your HDTV's aspect ratio.
m
0
l
September 11, 2011 3:06:10 PM

I was having this exact problem, and I just solved it, so hopefully it will work for you.

I went into the monitors settings, and under "input" I changed it from "HDMI AV" to "HDMI PC" and it now scales perfectly!
m
0
l
!