Sign in with
Sign up | Sign in
Your question

Another "Windows7 not seeing all my RAM" thread

Last response: in Memory
Share
November 16, 2012 1:02:32 PM

Ok, so I've done some searching on this issue, and so far I don't have any resolution. I have Windows 7 Professional, 64 bit, and it was only seeing 8 of my 12 GBs of DDR3 RAM. CPU-Z saw all 12 GBs. Thinking that maybe I just had some bad memory (and using it as an opportunity to upgrade), I purchased 24 GBs of DDR3-1600, and installed all 6 sticks last night. Now, Windows (and the BIOS) only sees 16 GBs of the 24. It seems that no matter what I do, the OS (and BIOS) only picks up 2/3 of my overall RAM. I do not have the "Maximum Memory" box checked in msconfig. Furthermore, I do not have any "memory remap" (or anything even close) in my BIOS. Here is a screenshot to show what I'm talking about... See the areas circled in red. The first screenshot shows what I was seeing with 12 GBs installed, here => http://i291.photobucket.com/albums/ll302/TRWeiss1/Windo...

This screenshot shows what I see now, with 24 GBs installed, here => http://i291.photobucket.com/albums/ll302/TRWeiss1/Not_S...

System Specs:

Intel i7 920 bloomfield @ 4.00GHz w/ Noctua U12-P
24GBs DDR3-1600 Ripjaws memory, triple channel
ASUS P6X58D Premium Mobo
Sapphire HD 7970 Vapor-X Ghz Edition
512GB OCZ SSD
Windows 7 Professional 64-bit

I also tried backing the overclock completely out. This doesn't change the amount of memory the system sees, even after reverting to factory specs. I thought I had found a shred of hope when I realized that I hadn't updated my BIOS in quite some time, and was on rev 1002. I went to ASUS' website, got the latest BIOS, and flashed it. My hopes were high, seeing as how several of the BIOS revisions were for "memory compatibility" fixes. Unfortunately, after flashing the BIOS to the most recent rev, it still only sees 2/3 of the memory.

Then, late last night I went even deeper into the twilight zone. I figured I'd try 1 stick of RAM in EACH slot, seeing if I could isolate any bad ones. You know, put 1 stick in 1 slot, power on, verify that it posts, check the memory in BIOS, move it to the next slot, then repeat... Know what I found? The PC won't even POST unless there is a stick of RAM in ALL 6 slots. How's that for weird? WTF is going on here?! If I knew for sure it was just a bad mobo (or bad slots) I'd just purchase a new one... It has been like this since day 1 though, since I built this rig back in '09.

What I think confuses me the most is WHERE is CPU-Z getting its data from?? Because it clearly always knows the correct amount of physical RAM installed. It saw the full 12 GBs when I had that installed, and now it sees the full 24 GBs. Now, if CPU-Z agreed with what the BIOS and Windows are reporting, it would seem to be an open and shut case of 2 bad DIMM slots... But CPU-Z reports the correct amount of memory EVERY TIME. Anyone ever heard of anything like this? Some insight/help would be much appreciated! Thanks. :D 

More about : windows7 ram thread

a b } Memory
a b $ Windows 7
November 16, 2012 1:22:37 PM

Hi, It was a common issue with the x58 boards. Some possible causes: bent pins (CPU socket) or a heavy CPU heatsink causing the board to bend and interrupting the RAM slots - CPU circuits. What I would try: clearing the CMOS firstly (unplug the power cord and remove the CMOS battery for few minutes), then testing the board outside the case, on a flat, non conducting surface and checking the CPU socket with a magnifying glass.
m
0
l
a b } Memory
November 16, 2012 1:27:27 PM

Is xmp profile enabled in the BIOS? Also check BIOS version should be 1402.
m
0
l
Related resources
November 16, 2012 1:38:12 PM

Thanks guys. Alex, I have heard about that issue with the CPU heatsink. Maybe I'll remove the heatsink and try re-applying it. I did clear the CMOS, although it didn't seem to have any effect on this problem.

Knight, what do you mean the "xmp profile"? I don't believe I've seen this option in the BIOS, but I'll look tonight. So the magic BIOS revision should be 1402, huh? Is that available right on their website? If you have a link that'd be much appreciated. :)  Otherwise, I'll look for it when I get out of work tonight.

Thanks again gents!!
m
0
l
November 16, 2012 1:44:49 PM

Nevermind, found the 1402 BIOS update. ;)  Will try that tonight!
m
0
l
November 16, 2012 4:41:33 PM

Thanks for trying to help guys... Unfortunately, removing and reseating the CPU (and heatsink) had no effect whatsoever. Inspected the CPU and socket carefully, and there are no bent pins.

Also, BIOS 1402 did not change how much memory the system could see either. I did find the XMP profile in the BIOS, though. Should I be using that or no? I'm currently just running with the OC I've had for years. I don't think it'd make a difference, because even when I back everything down to factory specs it still only sees 16 GBs.

It appears that I'm stuck with only 16 GBs, even though I have 24 installed. :\ Lastly, the MemOK LED works as it should when the board boots, and it is not on, so I don't imagine the board is trying to tell me there's a problem with the memory.
m
0
l
November 16, 2012 11:05:33 PM

I'm assuming you've tested each DIMM separately and in different slots?..
m
0
l
November 17, 2012 2:28:34 AM

Yes.
m
0
l
November 27, 2012 10:50:10 AM

Gents, as is turns out I've apparently had an issue with the memory controller on my i7 (since the controller is ON the CPU itself, not the mobo) since the day I bought it! Tried a friend's i7 and was able to see all the memory. However, I'm not going to be buying another old CPU. I decided to upgrade to the AMD FX-8350 8 core CPU, and just overhaul my system. This gives me a good excuse to do it. ;)  Thanks again for all the help!
m
0
l
!