Sign in with
Sign up | Sign in
Your question
Closed

AMD Vision Engine Control Center will not open.

Last response: in Graphics & Displays
Share
August 18, 2011 6:06:17 PM

I have spent hours researching fixes to this problem, and nothing helps. I have reinstalled drivers countless times to find that ccc still will not open. The drivers seem fine, but ccc just refuses to open.

So I tried opening MOM.exe in Task Manager... I see CCC.exe opening in task manager, but then it just disappears.

I also updated my .Net 4 with windows update, that did not help.

Any help would be greatly appreciated... Thank you.

More about : amd vision engine control center open

August 18, 2011 6:27:53 PM

AMD can be very picky about how a driver gets uninstalled. Have you tried running driver sweeper before reinstalling?
Score
0
August 18, 2011 7:07:05 PM

Yep, uninstalled driver with AMD... then deleted in device manager... Rebooted into safe mode, did driver scanner. Rebooted again and then did registry cleaner in safe mode. Finally installed the driver to no avail.
Score
0
Related resources
August 18, 2011 7:13:43 PM

Does the system recognize the card or is it not installing the driver because of "no compatable hardware detected" or whatever?

What card, motherboard, operating system, and driver version are you using?
Score
0
August 18, 2011 7:18:34 PM

I don't believe this is a recognition error... The driver is working fine, it is just that the Control Center will not open.

My card is a DIAMOND Viper Radeon HD 3850 512MB, Mobo is ASRock 890GX Pro3, operating system is W7 32-bit, Driver version is 11-8 Catalyst
Score
0
September 29, 2011 5:26:59 AM

I am also still looking for help after installing 11.8 drivers every time i try to start AMD control center mom.exe pop up in task manager and closes no-mater what i do i have disabled all the programs that might block it this is dumbest bug i seen from AMD, should of newer upgraded those drivers,,,, any1 got any solutions ( except redoing drivers running uninstaller driver sweepers or such other nonsense)
Score
0
!