Sign in with
Sign up | Sign in
Your question

HiS Radeon HD 6870 Causes desktop and open windows to flicker

Last response: in Graphics & Displays
Share
August 18, 2011 11:31:58 PM

Hello new to the forums here but I am desperate for help. I recently purchased an HiS Radeon HD6870 Model Number H687F1G2M and it worked fine for about a month. Now anytime I watch any type of video whether it be avi,mpeg youtube or whatever my desktops icons start flashing repeatedly along with any windows I may have open. If I click on the tol bar, the blinking stops until I click on the desktop or any open window. Does anyone know what may be causing this? I have an asus crosshair 3 mobo with 8 gigs of OCZ AMD Black Edition Ram AMD Phenom2 x2 550 cpu OCZ ModXStream Pro 700W Modular High Performance Power Supply compatible with Intel Sandybridge Core i3 i5 i7 and AMD Phenom with an Enzotech Extreme-X Rev.A 120mm 2 Ball CPU Cooler. Any help is greatly appreciated.
August 18, 2011 11:43:57 PM

Try downloading the latest drivers from the AMD website.After you install them restart.If that doesn't work then you might have gotten a faulty card.
m
0
l
August 19, 2011 12:03:49 AM

Ughh I hate to RMA this thing then have to wait for another card as my PC has no onboard video at all. Btw, I've went from catlyst 10.5 to 11.8
m
0
l
Related resources
August 19, 2011 1:01:42 AM

Has 11.8 worked for you?

HIS is known for making low quality units.Which is why they are always so much cheaper than other cards.
m
0
l
August 19, 2011 2:12:26 AM

No, none of them work. funny thing is it'll start flickering, I'll open a game and when I close it the flickering has stopped. All the reviews I had read about the card were fantastic and not many people had problems. Should've stuck with Sapphire like usual :( 
m
0
l
August 19, 2011 2:25:40 AM

Are you erasing the old drivers?

Is your version of Windows up to date?
m
0
l
August 19, 2011 7:46:04 PM

I've went as far as to reformatting my hd and starting from scratch. Running windows 7 Ultimate 64 all updates are current as of now.
m
0
l
August 19, 2011 7:47:07 PM

Has to be the card then.Is their anyway you can try it out in a different PC?
m
0
l
August 29, 2011 8:46:08 PM

nope no other pc other than mine here. It's likw windows explorer keeps refreshing.
m
0
l
August 29, 2011 8:47:54 PM

Can you try a different monitor? Just troubleshoot.Cancel out each possibility until your left with only one.
m
0
l
September 2, 2011 4:06:22 AM

purple stank said:
Can you try a different monitor? Just troubleshoot.Cancel out each possibility until your left with only one.

not the card, I put in my HD 4860 and the same thing happened. Not the OS either as I tried xp64 vista 64 and 7 64 all have the same problem on both cards as well. Not the monitor as it does it on another monitor. I guess my next step will be trying a dif. psu. really getting frustrated as it never happened before with the 4860 and I've had it a couple of years.
m
0
l
September 2, 2011 7:03:30 AM

At this point you might as well just RMA the 6870.A 700watt PSU is more than enough to run a Dual core and a 6870.
m
0
l
September 9, 2011 1:19:23 AM

purple stank said:
At this point you might as well just RMA the 6870.A 700watt PSU is more than enough to run a Dual core and a 6870.

Found out the problem. built this computer a year ago, Had a friend install what he said was a legit version of Window's 7 Enterprise on the thing for me. Come to find out, it wasn't. After purchasing Win 7 Ultimate x64 and installing it, the issue has went away and the computer runs flawless now. Moral of story, make sure your version of windows is authentic. Thanks for all of your suggestions!
m
0
l
!