I can connect to the internet and WoW But...

I can't connect to anything else... day of defeat source, lord of the rings online... nothing.

I've disabled my firewall and forwarded all the ports... nothing.

When I try to connect, sometimes It'll be stuck on connecting to server, or it'll go all the way, connect, but then instantly disconnect.

But I play WoW and I get 100 MS like it's nothing. No errors.

...What the hell?
9 answers Last reply
More about connect internet
  1. In windows at the lower right their is a two monitor icon if it has other things other than a globe (earth) then it needs to resolve that before you can connect to the internet. Try right clicking on it then click on Diagnose and Repair it will give you dialogs which you can choose to resolve the issues.
  2. Did that. Didn't work.
  3. Check TCP/IP Properties.

    Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.
  4. Was already enabled. I've tried everything I could think of, and nothing works.
  5. Disable Windows Firewall. Try connecting.

    Move the IP address of your computer (192.168.x.x) into the DMZ on your Router. This bypasses the firewall completely. Try to connect. If nothing, you have bigger issues.

    Do you have new anti-virus running that may be blocking the ports? Check there, disable if need be to determine if it is causing the problem.
  6. Disabling both the firewall, and stuck my computer in the DMZ was one of the first things I've done.

    I've tried...

    Disabling the firewall
    Port forwarded it all the ports that the various games used
    factory resetting the router
    Checking my TCP/IP settings
    Refreshing my IP
    Updating both my motherboard and Ethernet chipset's drivers
    running several virus scans.
    Disabling wireless access point (Don't know what this could of done, but it was worth a shot)
    fiddling around with my Router's settings.

    I wouldn't of come here if I hadn't tried everything I could think of. I'm pretty desperate because I need my FPS fix and none of them work. Think about it, all those noobs left unchecked...
  7. Eh, I don't know about jumping into the winsock resets right away. Eventually, true, but he does have a connection though only partially.

    Are they Steam games? If so, banned for hacking. :)
  8. I've got a PERFECT connection everywhere else.

    Most are Steam games, and I *CAN* Connect to the game, just only for a split second enough to hear a few shots fired before it disconnects me.

    Banned for hacking? No. One.) I don't hack because hacking is for bads. Two.) It would of given me a message in the affirmative if I had.

    I play World of Warcraft regularly and I can connect to it just fine, with 150 or less MS.

    I tried F2P Lord of the Rings online a few months back, but I would have the EXACT same problem I do with steam games.

    Connects for a split second then disconnects me, but sometimes hanging on various parts of the connection process.

    I didn't think it's a winsock issue, but I tried it anyway. Didn't work.

    And as a little addendum here, I do regular(Nightly) Malware/Virus scans. Quick scans daily and Full scans weekly.

    I've found nothing.
  9. Uninstall and re-install Steam. Looks like you should head over to the Steam forums to discuss.
Ask a new question

Read More

LAN Connection World Of Warcraft Internet Networking