Sign in with
Sign up | Sign in
Your question

INTEL S5520SCR - can't access BIOS, black screen

Tags:
  • Motherboards
  • BIOS
  • Intel
Last response: in Motherboards
Share
November 19, 2012 8:18:40 PM

MB intel s5520scr - worked fine for two years with win 7 pro.
one day didn't start up. system crashed.
since then i try to load up new system win 7pro one new(old ) hdd drve, previous system ssd drive've gone back to the shop. SO I've tryed hard...
changed something in BIOS config and that's it - black screen( screen doesn't wake up at all, nothing.... no reaction to pressing any keyboard buttons. i hear beeps 2-3( depending on quantity of usb slots taken) - pressing F2 should take me to bios menu.... perhaps it does but nothing happens , but system status led blinking amber light and ledlight code goes 01010100 as farrr as i can decode it its 0x54 nothing in the codes list except
Spoiler
0x53-0x57 Reserved for PCI Bus
:/  no idea... what to doo help pls.. KEYBOARD sometimes connect somtimes not. somtimes CTRL+ALT +DEL works , but sometimes not.

help pls anyone :pfff:  .

More about : intel s5520scr access bios black screen

a c 75 V Motherboard
a b å Intel
November 19, 2012 9:15:15 PM

The board has a 3 year warranty. So give our technical support a call at (916) 377-7000 and they will be happy to try to help you out.
November 20, 2012 3:08:20 PM

fantastiq!! thx. cmos and bios reset helped a lot. is there a representative like U in Poland? ... reagards from ....still.. an intel entusiast
Related resources
November 20, 2012 8:44:16 PM

ok. managed to enter bios. OS installation still stop almost at the end. - loaded(copied) preinstalled OS image on my HDD. system barely starts can't load any drivers for MBO and works like ***. entering CD - system hang up. cant read a CD now ( with or withoutCD inside a drive.) HARD Drive is HDD 500gb SATAII - aschi mode in BIOS'es mass storage maintaince setup.
CANT install anytnhing - OMG is the MBO fu **d up?
November 24, 2012 3:07:09 AM

EVERYthing's clear right now.
Instead of installing OS first next time we should load INTEL's Deployment assistant and load the chipsets drivers.
Again my mistake. gooodluck to everyone!
mark this solved

now.
I've got the problem with a PCU fan's constant top speed after starting up - reset deals with ths problem but again after turning off and on later happens again. cant find a place to fix that in bios and deploment menager active console tooo
!