Solved

Wrong Bios settings block Nic Realtek

Hello,
I have restarted Bios (by unplugging internal battery). Unfortunately Bios defaul settings (motherboard is: Asus P5 KPL ) seem not to recognize Nic E - Realtek Rtl 8101.
Internet is now available with Linux only.
(I have Windows Vista and Linux Debian in dual Boot; so I would exclude hardware problems).
Could pls. anybody suggest how to proper modify Bios settings ?
Many thanks
9
answers
Last reply
Best Answer
More about wrong bios settings block realtek
  1. If it works in Linux and not in Windows it's probably a driver issue, not bios. Download and install the latest Realtek lan driver from Asus for Vista.
  2. Best answer selected by AngeloU.
  3. Quote:
    Press the "del" key to enter the bios. Go to the "onboard devices configuration" in the "advanced" section. Find the "onboard PCIE ghz lan" and enable it.

    +

    On board Pcie 10/100 M lan [Enabled]
    I also c h a n g e d :
    Lan Option Rom [Enabled] (previous setting was : Disabled)

    At beginning Bios showed : wrong Realtek settings (some similar words) press shift + F10 .
    In that way I opened ''Realtek Pci Express Ethernet Boot Agent configuration menu '' .

    +
    The new setting is now :
    Boot order : Rom Disable
    At the screen bottom you read: Network Boot disabled, boot local devices
    +
    previous was: Boot Order Pnp/Bev (BBS)
    At the screen bottom writes : Boot ordered by BBS Bios, If BBS Bios present
    +
    Now I am not more able to press alt + F10 to change again, Bios system boots quickly and does not show any more ''wrong Realtek settings'' (similar).
  4. Unfortunately thread is n o t yet s o l v e d . (I choose best answer, since I still think problems are in Bios settings)
  5. If the nic is enabled in BIOS and boot ROM is disabled, then BIOS is all good and not your problem. You said internet works with Linux, that also indicates that BIOS is OK.

    If you still don't have internet in Windows it is probably the driver. Please go to this page, select your OS and download the Realtek LAN driver. Install it and see if that works.

    http://www.asus.com/Motherboards/Intel_Socket_775/P5KPLCM/#download
  6. :hello:

    It was more difficult than I imagined.
    I tried to download Nic Realtek Driver, following your suggestion.

    On download page I choose drivers for my system ( Vista 32 bit ) but unfortunately I only found :

    + LAN (7)
    (after clicking on on it)
    All drivers showed were: ATHEROS
  7. Have you tried to use the ASUS LiveUpdate Utility?

    There are a bunch of Asus P5KPL models, can you check on your motherboard and see if yours has more information about the specific model?

    For example, here is a sub-model with realtek drivers:
    http://www.asus.com/Motherboards/Intel_Socket_775/P5KPLAM/#download
  8. Your suggestion was completely right ! After installing proper Nic Realtek drivers I got again internet connections.
    Thanks.
  9. You're welcome. Glad we learned something today....
Ask a new question

Read More

Chipsets BIOS Realtek NIC Motherboards