Sign in with
Sign up | Sign in
Your question

USB 3 Drivers

Last response: in Components
Share
January 20, 2012 8:23:56 PM

I have a EVGA 3X SLI x58 MoBo.

I just got a USB3 thumbdrive and windows cant seem to install the drivers for it, and I cant seem to find them myself. Help Please.

More about : usb drivers

Related resources
a b \ Driver
January 20, 2012 8:39:31 PM

Is the USB3 controller enabled in BIOS?
m
0
l
January 20, 2012 8:51:18 PM

yes it is enabled
m
0
l
a b \ Driver
January 20, 2012 8:55:08 PM

The USB stick does not work at all? The driver support is a windows issue.
m
0
l
January 20, 2012 9:02:11 PM

The Drive works on my Laptop via USB2 no problem. it's just on my desktop that it wont work.
m
0
l
a b \ Driver
January 20, 2012 9:08:02 PM

neither USB3 or USB2? Any exclamation marks in device manager? Check windows update for updated drivers?
m
0
l
January 20, 2012 9:13:33 PM

the only ! in the DM is for the Marvell 91xx Config ATA Device. everything else is updated.
m
0
l
a b \ Driver
January 20, 2012 9:22:04 PM

Then I am lost.
m
0
l
January 20, 2012 9:41:31 PM

It detects the drive it just doesn't show up.....
m
0
l
a b \ Driver
January 20, 2012 9:48:19 PM

If you go in control panel/administrative tools/computer management/storage/disk management does it show up and assigned a drive letter?
m
0
l
January 20, 2012 9:49:29 PM

no, that's what threw me. I am wondering if I disable USB3 if it will work....
m
0
l
a b \ Driver
January 20, 2012 9:50:16 PM

Strange!
m
0
l
a b \ Driver
January 20, 2012 10:14:16 PM

Hi :) 

How many of your usb ports have you tried ? all of them INCLUDING usb 2 and 3 ? or just the 3 ports ?

All the best Brett :) 
m
0
l
January 23, 2012 12:01:04 PM

Brett928S2 said:
Hi :) 

How many of your usb ports have you tried ? all of them INCLUDING usb 2 and 3 ? or just the 3 ports ?

All the best Brett :) 

I HAVE in fact tried all of them.
m
0
l
January 30, 2012 3:00:12 AM

After Reinstalling widows for unrelated reasons everything seems to work.
m
0
l
a b \ Driver
January 30, 2012 10:20:31 AM

So basically a windows problem, not loading the drivers until after reinstall.
m
0
l
!