Solved

Sabertooth 990fx Problem

Hello,
So I've had this 990fx for a year and a halfish now and I attempted to update Bios. When it restarted, (and now every time i try to turn it on) I get the post "beep" and my keyboard and mouse both light up. But nothing shows up on the screen whatsoever. the Boot led light on the bottom of the motherboard itself is lit up however. Any ideas??

Thanks
6 answers Last reply Best Answer
More about sabertooth 990fx problem
  1. Try resetting BIOS but it is very well possible that you have a bad flash.
  2. Best answer
    Hi,

    Have you tried clearing the CMOS (unplug the power cord and remove the CMOS battery for few minutes)? Remove any USB memory stick. It might be that you forgot it there after flashing.
  3. I've cleared the CMOS a couple times, and the usb is out. How do i reset BIOS? And if i do have a bad flash, what do i do then?
  4. By clearing the CMOS you've reseted it.
    You can buy a BIOS chip and replace the board's one (from ASUS eStore in the US, ebay or other sites in Europe):
    http://www.youtube.com/watch?v=pLEQoWRq41k
  5. Ok, I thought as a last ditch effort to avoid a new bios chip, i reset cmos (via jumpers) 6 times in a row, and somehow managed to get it to post and i got into bios and got everything fixed. not sure why 6 times in a row fixed it when 1 or 2 times wouldnt. but everything is working fine now. Thanks for your help everyone!!
  6. Best answer selected by Schroeder369.
Ask a new question

Read More

Motherboards Sabertooth