Sign in with
Sign up | Sign in
Your question

My Dell latitude leptop doesn't start up

Last response: in Components
Share
January 22, 2012 8:36:26 AM

Can someone help me fixing this trouble?

when i press the power button it only lights on the led indicators but doesn't start up. even the cooler and the harddisk doesn't work.
a b ) Power supply
January 22, 2012 9:33:07 AM

Hi

Something which occasionally works on Dell & other laptops

disconnect mains PSU and remove battery
(check battery condition using test button and leds on Dell laptop batteries)

hold down power button for at least 30 seconds

replace battery & reconnect psu

try switching on again

This worked for me a few times but a few months latter motherboard died

(another thing to check that you still have memory modules (occasionally they get stolen if easily accessible))

regards
Mike Barnes
January 22, 2012 5:01:57 PM

I tried it but the result still the same...


Related resources
a b ) Power supply
January 22, 2012 10:34:33 PM

Hi :) 

If you tried all that and still no go...take it to a laptop repair shop to be diagnosed...

All the best Brett :) 
July 11, 2013 7:52:45 PM

pafro23 said:
I tried it but the result still the same...

This an old post but I saw it since I was looking for a solution to the same problem I am having with my Dell D520 core2duo laptop. The odd thing was that when I removed the memory from underneath the keyboard, it would startup. I tried different memory. The only thing was that i got it to work with just putting a 2 gig stick underneath and called it a day. I have no idea why the memory slot under the keyboard went. I have never run across this. I guess a first time for everything. At least it works, is all I can say but can never be upgraded to more memory. Diagnosed as a motherboard issue.




!