Single rear panel USB unresponsive

I'm using an Asus P8 Z68-V Pro mobo and like the title of the thread says, there is a single unresponsive USB port on the rear panel. To be honest I can't remember ever having anything plugged into this port. But, tonight I realized that it simply won't work.

Here's a picture what I'm talking about. Obviously the port circled in red is the troublesome one.

The three other ports work just fine. I've tried my mouse, keyboard and external drive in the fourth. No go.

Any thoughts?
3 answers Last reply
More about single rear panel unresponsive
  1. When plugging into the USB port, does it provide power?
    Is this mobo still under warranty?
  2. Sorry for the delayed reply, was out of town for the holidays.

    Well, I went to Asus and DLed the latest USB 3.0 drivers even though my 3.0 and 2.0 ports were working just fine. I know I have should have done that before posting but, it really seemed like a hardware problem, maybe a faulty port. Seems strange that a single USB port would stop working due to drivers. I've never DLed USB drivers in the past and have never experienced software problems with USB ports on any motherboard. But, everything seems to be in order now.

    Also, just for the record, that troublesome port wasn't putting out any power before the update which makes this even more weird.

    Thanks for the reply Novuake. Funny, your signature certainly applies to this one :pt1cable:
  3. LOL yes it does. The reason why your ports gave issues is because the USB 3 driver is not native to intel CPU, making it complicated. But im glad you sorted it out.
Ask a new question

Read More

Asus USB Motherboards