Can't access BIOS for the first time

Hi,

I have a Gigabyte GA-Z77X-UP4 TH motherboard with a Intel core I7 2600K. The graphics card I have is an MSI N660 TI. As the title says I can't access the BIOS screen. When I turn on the computer the Gigabyte logo appears with the various keys to hit. I start hitting the delete key on my ps2 keyboard right as I hit the power button. I have tried clearing the CMOS values by removing the battery on the motherboard for a couple of minutes, and by shorting out the two pins. Any help would be greatly appreciated.

Thank you
20 answers Last reply
More about access bios time
  1. Hi, Can you test a different kyboard (an USB one for example).
  2. Thanks. I'm going to try that in a bit...I got to go find one first. Could this be caused by unsupported RAM?
  3. What'sthe RAMs model?
  4. G.Skill Ripjaws. F3-1600C9D-16GXM
  5. Can't say for sure but you can use this ....Try making changes in the internal hardware.Like, If you got multiple RAM sets try taking one out so that the system gets time to analyze the change.Or disconnect the hardisk temporarily.
  6. Havw you installed 2 mdules? If yes, remove one and test with only one stick installed. A kit is a better option.
  7. So, I just tried using a usb keyboard and it did the same thing as the ps2 keyboard. The RAM is 8Gbx2 so ill try starting it up with just one in.
  8. I just tried starting it up with just one RAM and still no luck. Any thoughts?
  9. Weird. After removing the battery, did the system wait for F1 key?
  10. When I removed the motherboard battery and put it back in after a couple minutes it just started up like it has been. Should I have been prompted with the F1 key?
  11. Yes. Unplug the power cord and then remove the battery for few minutes.
  12. Okay I did that and no change. It just booted up like it has been. No prompt for F1 key
  13. No other ideas. It might be a BIOS issue.
  14. Alright. Thanks for your help. I really appreciate it.
  15. Try Disconnecting the HDD...
  16. I have taken detailed notes on exactly what happens when I press the power button. This is with the power supply, video card, CPU, CPU Fan, RAM, and case accessories connected to the motherboard.

    Display comes on (7 sec)
    1 Beep (8 Sec)
    Keyboard Lights i.e numlock light turns on (8 sec)
    Motherboard speaker making clicking noise every time I hit delete key (21 sec)
    1 Beep (Same as 1st beep) (35 sec)
    1 Beep (Same as other beeps) (1 min 3 sec)
    1 Beep (Same as other beeps) Screen goes black (1 min 38 sec)
    No other beeps, no clicking when keys are pressed.

    Note time is started when I hit power button, and the times are what the stopwatch reads. i.e the display comes on at 7 sec and 1 second later (8 sec) there is a beep
  17. FIRSTLY , when did you last used your BIOS ? Try to recollect what you did in BIOS at that time....
  18. creak said:
    Okay I did that and no change. It just booted up like it has been. No prompt for F1 key


    repeat it but this time do remember to discharge the chassis. that means, you turn off all power coming into the chassis, which means unplugging your monitor too. next remove the battery and press the power button a couple of time...this removes the static and will ensure that on reboot you are prompted with CMOS checksum error
  19. Hey everyone. I just wanted to let you guys know that I was finally able to get into the BIOS screen. I ended up disconnecting the video card, HDD, disk drive, and used the intel graphics. So, my next step is going to be connecting the disk drive, and my HDD. I'm then going to install Windows 7. Next, I'm going to install my chipset drivers. After those are installed i'm going to connect the graphics card and install the drivers for that. Does this sound okay? Do I need to install any other drivers?

    Thank you so much for all your help
  20. yes that task order is correct...go ahead :)
    best
    -satyam
Ask a new question

Read More

Motherboards