Sign in with
Sign up | Sign in
Your question

High ping time

Last response: in Networking
Share
November 23, 2010 2:04:20 PM

Hi
I used to have 20 to 50 ping time to my nearest ping test server, lately it started increasing and now it ranges from 130 to 200. what do u guys think the problem may be?
note: the ping is also high on my ps3 so I don't think the problem is with any program on my pc.
My router is AZTEC HW550-3G with bandwidth of 8mb cable. ( I didn't change any hardware lately).

More about : high ping time

November 24, 2010 7:20:29 AM

In situations like this I generally try changing the ethernet wires from modem - router if yours is set up like that.
If you're running both wirelessly then it could be something new you've got in the house, try changing the channel for the router. See if this sorts out your problem if not then it could the router itself, I'm sure some more experienced members of the community will have a better insight into what it is.
November 24, 2010 6:44:16 PM

my router is connected to the wall by a cable and also to the pc and the ps3 ( again by cable). The router also supports wireless connection but there is no new wireless device in the house, just the same things that we had before.
Related resources
November 24, 2010 8:13:11 PM

I did what u said and used the program. I tried largest MTU test and i got 1492( the number in the first page is 1500) so i think it is pretty close. but about the time to live value i'm not sure. in the first page it says my time to live value is 64 and i got this result for the avg latency test
Packets: Sent = 15, Received = 15, Lost = 0 (0% loss)
Approximate round trip times (RTT) in milli-seconds:
Minimum = 174ms, Maximum = 351ms, Average = 265ms
( i should mention that i'm currently living in UAE so i'm not sure how far i am from the servers.)
also i disabled my anti virus and firewall but no joy. ( as i said before i tested the connection on my ps3 and i got high ping time again. so i'm kind of thinking that the problem is not with a program on my PC.)

my largest MTU test gave me these results:
The largest possible non-fragmented packet is 1464 (1492 - 28 ICMP & IP headers).
You can set your MTU to 1492

also out of curiosity I did a trace test and i noticed that there is a jump from 9 to 213 in 6th line to 7th line. before 6th line its 0-3-3-4-6-9 and after line 7 it is 212-218-225-288-287-293.
December 12, 2010 4:23:02 PM

anyone?
October 3, 2013 5:37:07 PM

mayson said:
anyone?


After digging for a few years with the exact same problem, I may have found a solution.

First, the ping time is referenced from an internal timer in Windows. (I'm assuming your using Windows also.). The problem is that this timer may get delayed to be updated during boot.. somehow..

Just now, I finally found a site with a solution that appears to be working..

http://wiki.ljackson.us/Negative_Ping_Time

They recommend adding a line to your boot.ini file to use the PM timer instead of the Time Stamp Counter.

For the explanation:
http://blogs.technet.com/b/perfguru/archive/2008/02/18/...


Try the addition and see if it works for you. I have an office that had times of 400ms or better on almost every system, and after waiting 4 minutes for it to boot (strange issue I am also chasing), all ping times are 0, like they should have been..

The only real explanation is that it is related to the AMD processor.. not sure I agree, but it worked.

Hope this helps.
!