Sign in with
Sign up | Sign in
Your question

Ati replacement for nvidia GeForce8600M GT

Last response: in Graphics & Displays
Share
August 24, 2011 3:16:38 PM

Have a 3 year old Toshiba Satellite x-205 with dual Nvidia GeForce8600M GT cards. Got the 3 beep black screen a few days ago. Charger and batteries check out fine. Suspect the nvidia cards have died. Got no power whatsoever. Previously had a few episodes of system blacking and shutting down. waited about 15 minutes and repowered and rebooted with no problems untill now. Lots of posts of bad chips/boards Nvidia 8600. Any advice on replacing card(s) with ati radeon or another card. Thanks
August 24, 2011 3:26:17 PM

I had the same problem with the exact same card. After researching for a while, I only could find this problem with the 8600s...nothing about any of their other cards. So you're looking to keep the same laptop and just upgrade the card?

Huge nvidia fan and not that big into radeon...if you have the money and your mobo still supports it I'd check out the 580m. My roommates running 2 580 in sli (desktop) and absolutely loves it.

Here's a couple of articles:

http://www.notebookcheck.net/NVIDIA-GeForce-GTX-580M.56...

http://www.gizmag.com/nvidia-geforce-gtx-580m-gpu/19067...
m
0
l
August 24, 2011 3:29:29 PM

My suggestion is to stick with Nvidia. I gave up on ATI years ago for buggy drivers. Last year I decided to try one again and am sorry I did. the drivers are still buggy and I suspect they always will be. You'll find plenty of people to disagree with me saying that everybody has buggy drivers sometimes. I agree but with ATI/AMD it's the rule rather than the exception.
m
0
l
a b Î Nvidia
August 24, 2011 3:30:48 PM

First, it looks like you are stuck with a Nvidia based solution. Second, it also appears that you will need to check with Toshiba for your options. While it may be possible to repair/replace the GPUs in your rig, unless under warranty, it is going to be expensive.

The manual for your rig can be found at:
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/mod...

m
0
l
!