Sign in with
Sign up | Sign in
Your question

Help with my Asrock z77 Extreme4! DIMM slots A1 and A2 are not working

Tags:
  • Motherboards
Last response: in Motherboards
Share
November 25, 2012 7:49:34 AM

Recently I tried to clean my pc so I had to remove all of the components and put them back together after cleaning. Usually at first boot i would get the Dr Debug Error 55 meaning there's no ram and what i just usually do is just reposition them (From A1 and B1 to A2 and B2 or vice versa). But today wherever i reposition them, I would always get the error 55. Tried to just use 1 stick (i use 2x4gb patriot 1333mhz btw) and both sticks were fine at B1 and B2 slots but at A1 and A2 slots always show the error 55. My rig's just about 2 months old so everything's quite new.

I have updated bios and only 1 hdd and my psu's more than enough for my rig.

Is my motherboard already busted? Because it's really hard to get a replacement here in my country especially at the store where I bought it because they really are a pain in the as* whenever they interrogate me about mishandling and the likes.

More about : asrock z77 extreme4 dimm slots working

a c 559 V Motherboard
November 25, 2012 8:06:39 AM

I would remove the CPU and check the socket for bent pins (use a magnifying glass or take a hi-res picture).
m
0
l
November 25, 2012 9:09:09 AM

I just did that and saw 1 pin(upper right part of the socket) is bent a little to the left. is this repairable? This is the first time I encountered this so I'm really a noob here.
m
0
l
November 25, 2012 9:16:22 AM

another thing. Is it just me or did my pc just went A little bit faster? I tried to benchmark my NBA 2k13 and Borderlands 2 games on highest settings(physx on) and the ave fps of both games went up in 2x4gb single channel config. about 40+ increase in NBA 2k13(60+ to 100+ fps) and abut 10-15 fps in Borderlands 2 (55+ to 65+ fps). Really really wierd considering. Also the boot up time was considerably less than when i was in dual channel mode.
m
0
l
!