Sign in with
Sign up | Sign in
Your question
Solved

BIOS Got messed up after a forced quit

Last response: in Motherboards
Share
November 25, 2012 10:48:07 AM

Recently I experienced something weird on my computer. When I wanted my computer to go into stand-by, it got stuck at a certain point: everything seemed to be shut down, (I got no input on my monitor, neither seemed the USB-connected devices get any power) but the fans were still spining... I couldn't get my computer out of stand-by anymore and I was forced to shut down the computer manually.

This problem has occured before (standby, while the fans kept spinning), but it usually didn't harm anything. Beside the fact I always lost the data of the processes that were running... But this time, something strange happened. When I booted the computer back up, a lot of settings seemed to be changed. ASUS Express Gate had been enabled, my RAID configuration was gone, the order of the Hard Disk drives seemed to be messed up and most important of all: my Windows couldn't boot anymore. I solved these problems quite quickly; I got my data from the RAID disks back, my Windows ran fine again, but one problem hasn't gone away: all the fans run at 100%.

I can adjust the fan speeds with speedfan.... but I don't like to be dependent on tools. My fans (3 casefans, cpu-fan and gpu-fan) used to work properly. Although there are connected by a 3-pins connector, they have had the ability to adjust the fanspeed depending on the workload. Now, they are stuck at full speed. Q-fancontrol doesn't seem to work either, setting the cpu-fanspeed to Q-fan control results in a CPU-fan Error during POST.
Actually, I don't remember having Q-fan control enabled previously, so it should work without it. I haven't changed these settings when I build my system...

Please, does anybody know how my fans could get up messed up so bad?

I've got a ASUS P6X58D-E motherboard. I've already tried to reconnect all the fans... without success...

Regards,
dvtoxic

P.S.: This is my very first post in this forum. I hope this is the right section. ^^
a b V Motherboard
November 25, 2012 12:13:39 PM

When you re-configured your bios did you enable the CPU & Chassis Q-Fan controls in the Power section?
m
0
l
November 25, 2012 1:01:34 PM

Yes, I tried this. Chassis Q-Fan control doesn't really help. And Enabling CPU Q-Fan control results in a CPU fan error, regardless of the preset...
m
0
l
Related resources

Best solution

a b V Motherboard
November 25, 2012 1:35:06 PM

Oh, sorry I missed that in your original post.

You say speedfan is able to adjust all the fans? I would just put speedfan in my startup folder and let it do it's thing.

Have you checked for BIOS updates? At least reset your BIOS to default with the jumper or battery and re-configure. If your computer was quiet before all this happened I suspect Q-fan was enabled. Otherwise all fans would have run at max.
Share
November 25, 2012 2:05:59 PM

I prefer to don't be dependent on tools like speedfan. Besides I have got a dual boot with Ubuntu, and there is very small offer of fancontrol tools for Linux. Lastly, Speedfan doesn't start up properly, when it's placed in the startup folder or scheduled by Windows Scheduler...

I will try to reset the BIOS to default and, if this doesn't work, to update it... Do you recommend to do this with the ASUS Update utility or the ASUS EZ Flash 2 with usb flash drive?

P.S. 2 newer versions are available. One of them (v0701) is just 1,06MB. (Which is typical for BIOS firmware) another one (v0803) is 252,7MB !
m
0
l
a b V Motherboard
November 25, 2012 2:11:31 PM

I've used the ASUS Update without any problems. The 803 version may be a zip file with the update and other documentation/files. Download it and check it out.

Oh, and you have to set the shortcut for speedfan to run as administrator for it to work in startup. Right click the icon, properties, shortcut, advanced, click Run as Administrator.
m
0
l
November 25, 2012 3:18:01 PM

Okay, I'm trying the first step you provided: resetting the BIOS. I've reset the BIOS by holding the "clear CMOS" button for a couple of seconds. The I enabled Chassis Q-Fan control at "Silent" and CPU Fan Q-Fan control at "Standard", which resulted in a CPU-fan error again. I pressed 'F2' to resume, and after I switched PWM1 and PWM2 in Speedfan to "Smartfan 4" it seems to be working again.
After boot: all fans were running quietly...
So it looks good for now, thanks for the help...

I've got a few questions though:
- Why do I still get a Error message? It gives a few beeps.. and displays "CPU Fan error"
- What is Smartfan 3?

P.S. The error disappeared when I set the CPU Q-Fan control to manual and the minimal fan speed to 50%. Apparantly the CPU fan can't run below 50%. I noticed that the fanspeeds increase when I work with a heavy workload. But the fanspeeds increase even more when I start up SpeedFan, while nothing is set to manual anymore but to Smartfan 4... ( It shouldn't be able to change it then anymore... )
m
0
l
a b V Motherboard
November 25, 2012 6:16:32 PM

Well, I guess that worked. I would still update the bios.
m
0
l
November 25, 2012 7:05:31 PM

Owkay, thank you for the help. :) 
I guess after all that the reset option within the BIOS isn't quite the same as resetting the bios by clearing the CMOS...
m
0
l
November 25, 2012 7:05:44 PM

Best answer selected by dvtoxic.
m
0
l
!