Sign in with
Sign up | Sign in
Your question
Closed

Random Freezes on new build

Last response: in Systems
Share
October 24, 2011 9:16:04 PM

Just built a new PC, and I have been having issues with the computer locking up, seemingly randomly, and I was hoping the good people here could help. Sometimes it will stay on for almost 24-hours with out issue, and other times it will lock up within 20 minutes. It seems like it has always frozen up while watching video, but watching video is also the primary role of the PC (so it may just be coincidence).

Hardware:
OCZ ZX Series 850W PSU
AMD FX-8150
Asrock Fatal1ty Professional 990fx
G.Skill 1866 Ram 4x4GB
Nvidia GTS 250
Corsair Force GT 120GB SSD


The freeze leaves whatever was last rendered on the screen, the mouse and keyboard simply stop responding, numlock doesn't toggle, ssh connections into the box no longer go through, but the system maintains power and has not bsoded or kernel panicked. The fans stay on everything is just frozen.

I have seen it freeze in Ubuntu 11.10, Windows 7 x64 Prof, and an Ubuntu 11.10 live usb stick. The graphics card I actually pulled from my old pc, on which it worked flawlessly. I have run memtest twice now with no errors (first the windows memtest, and then the memtest that comes on most linux live cds). I have ran Prime95 for a good 30-40 minutes while I went out to get food with no issues. The CPU was just under 70C with the load from Prime95, most of the time it idles around 32-35C. Handbrake has ripped several movies without issue for me (love the speed of handbrake compared to my old rig). I also played through several hours of Oblivion without issue.

My best guess from reading is that it may be my RAM/Mobo/CPU combination and no individual component. Even though the Asrock board markets a supported RAM speed of 1866Mhz, and even though I have a bulldozer CPU, the motherboard seems to only want to run the RAM at 1600Mhz. At the moment I have left everything at auto, but when I manually tried setting the RAM speed to 1333Mhz, I still encountered the freezing issue.

I would really appreciate any help or advice anybody has to offer. I'd like to be able to have my main PC double as a sever (for things line minecraft with friends), but when it randomly freezes and requires a hard reset to get back, I can't really do that.

As you can probably guess from the components, the build is just over a week old. The GPU is the only component that isn't brand new.

P.S. Last time it froze CPU temp was at 35C and M/B temp was at 33C
Vcore Voltage 1.069 V
+3.3Voltage 3.312V
+5.0V Voltage 5.040V
+12V Voltage 12.302
CPU NB Voltage 1.1625V
DRAM Voltage 1.500V
NB Voltage 1.145V
HT Voltage 1.180V

Running the latest official firmware from Asrock (1.30)
When it froze in linux I was able to get a GPU temp of 113F or 45C

I think my next step is either contact G.Skill or Asrock, unless someone hear knows some magic voodoo. I have heard that high-end RAM often needs manually set, so if somebody could help me with that (if they think that is the problem), I would appreciate that as well.

Thanks

More about : random freezes build

October 24, 2011 9:18:40 PM

mm.. tried doing a Memory Stress test or GPU stress test?

If you running Win7, the memory tester in built into it.
Score
0
October 24, 2011 9:21:27 PM

Have not tried a Memory stress test aside from memtest, do memory stress tests do something different? Is the memory tester in Win7 different from the recovery console memory test (I have already run that). What would be a good GPU stress test?

Thanks

P.S. In case they are helpful/relavent, last time the PC froze in windows these were clock specifications as read by F-Stream tuning utility

CPU speed: 3314.55 Mhz
CPU Frequency 201 Mhz
CPU Frequency Multiplier 16.5
PCIE Frequency 100 Mhz
HT Bus Speed 2008.82 Mhz
NB Speed 803.53 Mhz
Score
0
Related resources

Best solution

a b B Homebuilt system
October 24, 2011 9:24:06 PM

What are your ram timings at? You can also enable the xmp profile to see if that will prevent the freezing.

It could also be a bug that's new with the mobo. Check to see if there is a new bios update that could be a potential issue. I've also had issues with an AMD cpu with an nvidia graphics card where the amd graphics conflict with the nvidia driver.
Share
October 24, 2011 9:31:00 PM

According to CPU-Z
DRAM Frequency 803.5 Mhz
FSB:D RAM 1:4
CL: 11
tRCD: 11
tRP: 11
tRAS: 28
tRC: 39

JEDEC #4
Frequency: 685 Mhz
CAS# LAtency 9.0
RAS# to CAS# 9
RAS# Precharge 9
tRAS 24
tRC 33
Commant Rate: blank
Voltage 1.5V

JEDEC #5
Frequency: 761 Mhz
CAS# LAtency 10.0
RAS# to CAS# 10
RAS# Precharge 10
tRAS 27
tRC 37
Commant Rate: blank
Voltage 1.5V

JEDEC #6
Frequency: 838 Mhz
CAS# LAtency 11.0
RAS# to CAS# 11
RAS# Precharge 11
tRAS 30
tRC 41
Commant Rate: blank
Voltage 1.5V

XMP-1866
Frequency: 933 Mhz
CAS# LAtency 9.0
RAS# to CAS# 11
RAS# Precharge 9
tRAS 29
tRC 42
Commant Rate: 1T
Voltage 1.5V
Score
0
October 24, 2011 9:32:59 PM

rozz said:
I believe Memtest is 32bit (will only see about 3.5GB of memory) so in order for you to work it, you will need to do 1 stick at a time.

Win7 memory test should test all RAM (it is 64bit compatible).

http://www.sevenforums.com/tutorials/715-memory-diagnos...


Based on what I see at the link, Win 7 memory diagnostics is exactly what I ran first (before memtest) with no errors found.

P.S. Sorry for the double post. My mistake.
Score
0
a b B Homebuilt system
October 24, 2011 11:03:30 PM

ZaelFaroe said:

XMP-1866
Frequency: 933 Mhz
CAS# LAtency 9.0
RAS# to CAS# 11
RAS# Precharge 9
tRAS 29
tRC 42
Commant Rate: 1T
Voltage 1.5V


Go into your bios and enable your xmp profile...your ram should be fine where it is at but it could be acting up with the odd timings/frequency.
Score
0
October 25, 2011 1:44:53 AM

Looking around I don't see xmp as a BIOS option. Isn't xmp an intel-only extension?

P.S. This evening it froze on me while no video was playing (didn't really think video had anything to do with it)
Score
0
a b B Homebuilt system
October 25, 2011 3:14:27 PM

You are right, you have to manually do it for AMD although manually setting the xmp profile doesn't work as well.

Is it freezing due to inactivity? Like trying to go to hybernate and glitching? Is your power setting set to high performance?
Score
0
October 25, 2011 4:11:56 PM

Power Settings are definitely at high performance. The first thing I did was disable all the power management settings.

FYI: It does seem like most of the time it freezes are during periods where it is mostly idle, but it also goes through period of much greater idle activity without freezing. I don't think it has frozen on me yet when I was actively interacting (as long as we don't count watching videos as actively interacting).

Update:
I don't know, what was causing the freezes/lockups, but it looks like a BIOS update (on whim) fixed the issue. I am now running the 1.47 beta bios for the AsRock Fatal1ty Professional 990fx board, and for the first time with this computer I have broken 24 hours of uptime. I am actually at 41 hours quickly approaching 48 hours of uptime, but the system had never previously made it longer than about 16 or 18 hours. I think once I hit 48 hours I will officially consider this resolved unless it happens again. If anybody else has an issue similar to mine, with the specs similar to mine, this is the solution that has seemed to work for me so far.
Score
0
October 27, 2011 3:47:25 AM

Best answer selected by ZaelFaroe.
Score
0
November 30, 2011 12:21:09 PM

I am having the same problem with 4 sitcks of 4gb G. Skill 1866mhz ram, I set the voltage in the bios to factory specs for the ram @ 1.5v and set the timings to factory specs @ 9-10-9-28-2T and system will freeze at random, sometimes in bios sometimes not until windows begins to boot (then it BSOD's). This board is rated for 1866mhz without OC'ing with bios version 1.50. I'm currious to know if this is due to the fact that all 4 dram banks are occupide as with some other boards and not running ram at factory specs when all 4 banks are taken
Score
0
!