Sign in with
Sign up | Sign in
Your question
Closed

Acer Aspire x3950 Hangs Randomly

Last response: in Systems
Share
October 25, 2011 8:52:02 AM

Hello everyone,

My girlfriend's Acer Aspire X3950 has been giving me such problems over the past few weeks despite multiple attempts to troubleshoot such that I really need any ideas as to what could be the issue.

Specs:
i3-540
4GB Ram
HD 5570 (which I added in myself)
Windows 7 Ultimate 64-bit (with SP1 installed)

Everything was fine and dandy for a really long time (even after the addition of the HD 5570) until last month when it started to randomly hang every 3 or 4 days. Note that it doesn't crash to a BSOD. It just hangs.

Here's what I've tried so far:
1) I've updated all drivers to no avail.
2) I've done a wipe and a clean install of Windows and updates. The problem came right back in the very first week of the new installation.
3) Fearing that it's an issue with the PSU not being able to handle the HD 5570 or an issue with the HD 5570 itself, I have also removed the HD 5570 and reverted back to using the integrated graphics. The problem still persists. Also a new problem has arisen: sometimes after it hangs, restarting it will cause the damn Acer not to POST. I have to repeatedly restart it until it POSTs.

I'm leaning towards thinking that it's a mobo problem, though that may just be me thinking (perhaps unjustifiably) that proprietary OEM mobos are crap.

Any suggestions as to what the problem might be would be helpful.
January 11, 2012 9:12:53 PM

Hey may i ask how you fitted the HD 5570? looked in my case there is litterally no space for a gfx
Score
0

Best solution

January 12, 2012 8:08:40 PM

Did you pull the memory sticks and run them one at a time? Have you scanned the HDD with a free diagnostic software to see if there are any bad sectors?

The GPU is fine if this is still happening on integrated, and the PSU is (likely) fine as well.

OEM motherboards are crap, depending on who to talk to.
Share
Related resources
January 22, 2012 12:29:35 AM

jakemcintyre99 said:
Hey may i ask how you fitted the HD 5570? looked in my case there is litterally no space for a gfx


You can. Needs to be a half height version.
Score
0
January 22, 2012 12:31:21 AM

Thanks for the help guys. I swapped out for a non-OEM mobo and everything's fine. Acer makes rubbish stuff really.
Score
0
February 1, 2012 12:26:48 AM

Best answer selected by metamok.
Score
0
February 6, 2013 5:31:08 PM

metamok said:
Thanks for the help guys. I swapped out for a non-OEM mobo and everything's fine. Acer makes rubbish stuff really.


I got the same pb / can you tell us which motherboard you used to solve the pb
Thanks
Score
0
!