Asus m4a78t-e and fx-6300 no display. Help!

Hey guys,

So I have an asus m4a78t-e motherboard and just bought an amd fx-6300. When I installed it, the system started up but there was no display on my monitor. I reset the bios to default but still nothing. Also, the power button won't work once started up and I have to pull out the power plug to turn it off.

Any idea what's going on here? Is my mobo not compatible?

Thanks for any help!
3 answers Last reply
More about asus m4a78t 6300 display help
  1. Looking at the CPU support list for that board, I do not see any FX CPUs listed. That would very likely be a source of problems.

    http://www.asus.com/Motherboards/AMD_AM3/M4A78LT/#CPUS
  2. Oh god. I fear I was too hasty in buying this fx CPU. Any suggestions for a mobo (cheaper the better) that could support it? Or would you suggest I just get the phenom x6 1100t, or similar CPU and RMA this one?

    I am new to all this :)

    Thanks for your reply
  3. iahwhite said:
    Oh god. I fear I was too hasty in buying this fx CPU. Any suggestions for a mobo (cheaper the better) that could support it? Or would you suggest I just get the phenom x6 1100t, or similar CPU and RMA this one?

    I am new to all this :)

    Thanks for your reply


    Given my position, I try and avoid making any recommendations regarding what to buy. So maybe someone else, unencumbered by being a company rep, will be able to offer up some suggestions. Generally speaking, I would start looking at motherboards within your budget, make sure that they support the FX, and then compare that against buying a CPU supported by the board you already have. Go with whichever is cheaper. Then you can try and return whichever part you have left over, or worst case scenario, put it up on eBay or something and sell it.
Ask a new question

Read More

Motherboards Asus Displays