Sign in with
Sign up | Sign in
Your question

AMD A8-3850 + XFX HD6670 Crossfire Distortion

Last response: in Graphics & Displays
Share
August 31, 2011 12:39:53 AM

Hello,

I just recently purchased an XFX Radeon HD6670 to Crossfire with my AMD A8-3850 APU. Upon putting the card in, activating "Dual Graphics" in the BIOS, installing drivers and activating Crossfire in the AMD Vision Engine Control Center, my games and the Control Center itself is all distorted. I've tried a few different drivers people suggested on other forums (such as 11.6b) but I've had no luck. I've tested both the APU and the card individually and both work just fine separately. It is also worth noting that I did not see the "6690D2" under my Display Adapters in the management console, signaling the Crossfire. As you can see from my pictures included, CCC is reporting successful Crossfire, however I can not test anything with it since I cannot see games without the distortion.

System Specs:
Windows Vista Home Premium SP2 64-bit
AMD A8-3850 APU
XFX Radeon HD6670 1GB DDR5
8GB DDR3 1333 RAM
450W TT-450 PSU
A75MA-G55 MSI Motherboard
1TB HDD 5900RPM





*EDIT*Not sure why pictures aren't working?*EDIT*

Thanks for your help!
August 31, 2011 11:18:16 AM

So finally figured it out. Surprisingly, I found the solution in a review of the processor and not on a forum! For any poor soul that is looking for the answer to this problem, this is what I found:

"By default, Llano wants to be the primary output. So, when you configure your BIOS, set up Windows, and get drivers installed, AMD says use the APU’s outputs. If there’s a discrete card installed, CrossFire gets enabled automatically. At that point you have to install the latest Application Profiles patch, disable CrossFire, shut the system down, and switch over to the discrete outputs. From then on, you won’t see a video signal until Windows loads up. Enable CrossFire, reboot again, and then you should be able to use Dual Graphics. Whew."

Follow those steps exactly and you will have your problem fixed. Thanks to anyone who read this and tried to help me out.
m
0
l
!