Sign in with
Sign up | Sign in
Your question

Cannot access Bios, but rest of the system works fine!

Last response: in Motherboards
Share
November 30, 2012 1:06:53 PM


Hi,

I recently assembled this new system of mine.

It's got a Gigabyte GA-H77M-D3H motherboard
Core i7 3770k (i know about the non-overclocking issue of the motherboard, plan to change it mid 2013)
Corsair Vengence 1600 2x8GB
and I'm using my old GPU GTX 260 core 216 and the PSU is Cooler master 650w bronze series.

My system works fine, but when I try to enter the Bios, the startup screen of bios loads, where it says the motherboard company name and then the system hangs. Only resetting it works. Nothing responds. Been trying to enter the bios for a week now.

Any suggestion would be appreciated!

Thanks in advance
Sabby Jay
November 30, 2012 2:36:59 PM

Are you using a wireless keyboard?
m
0
l
November 30, 2012 4:09:26 PM

Yes, I am using a wireless keyboard and mouse.
That was the first thing I suspected, so I tried wired keyboard and mouse. Still the same problem.

Thanks for your input though!
m
0
l
Related resources
a b V Motherboard
November 30, 2012 5:33:30 PM

Are you using Windows 8?
m
0
l
December 1, 2012 5:17:20 AM

Nope, I'm using Windows 7 Ultimate 64-bit.
m
0
l
a b V Motherboard
December 3, 2012 1:39:14 PM

Is the wired keyboard you used USB? If so, try a PS/2 keyboard, sometimes they work better to get into BIOS. If that doesn't work I'd RMA the motherboard because if you can't get into BIOS something is badly wrong....
m
0
l
December 10, 2012 6:05:47 AM

Yes I used a wired USB keyboard. I'll first have to find a PS/2 keyboard.
Can it be an issue with the display type? Because I remember that the Bios was working at the shop I bought the motherboard from on the ol CRT monitor.
m
0
l
a b V Motherboard
December 10, 2012 12:35:30 PM

Probably not related to the display. I've had some motherboards not detect usb keyboards until after bios. That may be the problem. If you get a ps/2 keyboard and can get into bios try changing some of the usb settings and then switch back to your usb and see if it works.
m
0
l
!