Sign in with
Sign up | Sign in
Your question

"D:\ is Not a valid Win32 Application"

Last response: in Systems
Share
October 28, 2011 3:48:29 PM

Hello, I am here in regards to a problem with my CD/DVD drive. I just built a new computer, so I will start with it's specs..

MSI P67A-GD65 Mobo
WD RE4 64MB 7200 RPM HDD
Intel i5-2500k
nVidia GTX 560
Corsair TX 850-W PSU
Corsair Vengeance RAM (2x 4gb => 8g total)
Lite-On CD/DVD ROM
Rosewill Challenger case
Windows 7 home premium

Please note this is my first computer build.

Basically, I installed all the parts, seems that everything works fine, no DoA parts. I installed Windows 7 and then popped in the MSI chipset Drivers and Utilities CD, only to be given the error message, "D:/ is not a valid Win32 Application" every time I insert and try to run this disk. I have tried bypassing the auto-run and executing the install file from the disk via windows explorer, still to won't work. It's almost as if I hooked up my CD/DVD ROM drive wrong? I cannot think of how I would have done that, though.. (Please note: in this post http://www.tomshardware.com/forum/168608-31-urgent-vali... - WIKWAK (user who's post is near bottom of page) explained what could have been the problem - and it sounds quite like what is happening, however his solution did not help me.)

Basically, what is causing this error message and how do I fix it? I can't do anything until I install these drivers. Do I absolutely need to have the computer hooked up to a LAN connection to get it started? I was going to put my wireless NIC drivers on a USB and install them on the computer so that I wouldn't have to move my computer and hook it up to the LAN.

other notes: I have tried booting to the CD-ROM itself and it then installed a LINUX OS - nothing huge, but a command-line based version of linux. That is certainly not what I want, either.

I'm sorry this is such a long post, but it should have all the information necessary for troubleshooting.

Thanks!
October 28, 2011 5:00:13 PM

Does this problem occur only with the "MSI chipset Drivers and Utilities CD"?

If so the CD itself may be damaged, I suggest you grab whatever drivers you need online

You should have a look in the windows "Event viewer" for any errors related to the cd/dvd drive as well

Have you tried copying the content of the CD to your HardDrive and running it from there?

If the problem occurs for other CDs or DVDs then the problem is elsewhere and I hope someone else will be able to help you.

Googling it might help the issue seems to be somewhat frequent and suggestions I've seen so far range from bybassing the autorun and manually running whatever exectuable it referenced, to trying to run it in safe mode which might indicate that a service or driver that is not loaded in safe mode might be causing the issue.
m
0
l
October 28, 2011 9:36:44 PM

This topic has been moved from the section Storage to section Systems by Area51reopened
m
0
l
!