Sign-in / Sign-up
Your question

PC wont turn on I think i fried the RAM slots help!!!!

Tags:
  • Asus
  • Light
  • RAM
  • Green
  • Motherboards
Last response: in Motherboards
November 30, 2012 9:18:53 PM

I pulled out the ram while the pc was on the green light on the mobo is on which means its getting power did i fry the ram slots and the ram????

More about : wont turn fried ram slots

a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 9:21:29 PM

I don't think so. Have you inserted it back and it doesn't work?
m
0
l
November 30, 2012 9:23:12 PM

yes it doesnt i even tryed a acouple diffrent kinds of ram and it still wont turn on
m
0
l
Related resources
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 9:26:15 PM

Did the board work before unplugging the RAM?
m
0
l
November 30, 2012 9:26:53 PM

yes
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 9:31:02 PM

Have you tried starting with only one RAM stick (each slot)?
m
0
l
November 30, 2012 9:43:53 PM

yes
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 9:45:16 PM

Then it might be a board issue, or a CPU one. Try testing the components at a local shop.
m
0
l
November 30, 2012 9:48:15 PM

the charge 130 for any king of testing like that at my nearest shop
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 9:52:01 PM

Wow. You can buy a new CPU or motherboard with that money. Can you connect a case speaker to the motherboard?
What you can also try is unplugging the power cord and pressing the power switch for 20-30 seconds.
m
0
l
November 30, 2012 9:58:10 PM

yes it makes no sounds at all no beeps to indicate anything
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 10:01:42 PM

Try starting the board with only CPU and CPU fan installed. Check if the CPU fan does spin. You should get the error beeps signaling no RAMs installed.
m
0
l
November 30, 2012 10:03:11 PM

nope nothing
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 10:03:44 PM

Is the CPU fan spinning?
m
0
l
November 30, 2012 10:05:32 PM

no
m
0
l
a c 1496 V Motherboard
a c 457 Ĉ ASUS
November 30, 2012 10:11:00 PM

Then it's either a power supply (not providing 12V through the CPU ATX connector) or a motherboard issue. Do the case fans spin?
m
0
l
a b V Motherboard
a b Ĉ ASUS
November 30, 2012 10:22:41 PM

Are you sure the power supply is working? Were you wearing a grounding strap or were you grounded when you reached in your computer? You know the spark from your hands from static can damage your motherboard that is why you should be wearing a grounding strap when your working on your computer. Try unplugging the all the power connectors from the motherboard then reconnect them.
m
0
l
November 30, 2012 10:42:55 PM

the psu is working because it is providing power to the motherboard because the green led at the bottom indicates it is and i did try what you said and nothing is working. by the way thank you guys for all the help keep it coming please
m
0
l