Computer won't boot after BIOS update

I have an ASUS P8P67 M-PRO motherboard, and after updating the BIOS to the latest version, the computer doesn't seem to boot - it sounds like it's powering on, the fans run, but the screen just stays black.

Here's how I got to this issue: I installed a new SSD (Kingston HyperX 120GB) today, and I had to get into the BIOS to change the boot order, but it turns out that I had forgotten the BIOS password. I cleared the CMOS RTC RAM to reset it.

Then later when I was installing Firefox, I got a BSOD that said "A clock interrupt was not received on a secondary processor within the allocated time interval." Rebooted and kind of ignored it and went about my business to see if it'd happen again, and it did a few hours later when I was playing a game, so I looked it up and found that it could either be due to an unstable CPU overclock (my CPU is not overclocked), or needing to update the BIOS. So I updated the BIOS, and now here I am. I've read some advice that said to clear the CMOS, but I've tried that like 5 times now and it didn't seem to affect anything.

I haven't had any issues at all with my computer since I built it a year and a half ago. I feel like there shouldn't be anything wrong with my motherboard because I've used it for that long without any issues, but I dunno. Any help would be greatly appreciated!
5 answers Last reply
More about computer boot bios update
  1. When you used the cmos jumper to clear the password did you move it back?
  2. Was The update process successfully completed?

    1. Try starting with only one ram card one by one

    2. Try removing the SSD.

    3. Check power cables monitor, motherboard, dvi/hdmi cable

    If these things don't work then your bios may be corrupt, go to an asus service centre to sort the problems out.
  3. Remove processor and fit correctly. check the cmos battery has power or try to change that.
  4. bignastyid said:
    When you used the cmos jumper to clear the password did you move it back?

    Yes, I did.

    Anonymous said:
    Was The update process successfully completed?

    It said that it was successful and that it'd reboot, and that's when I started having the problem.

    Thanks everyone for the suggestions, I'll try them.
  5. Turns out that it didn't like the fact that my HD 6950 was flashed to a 6970. I flipped the switch to make the graphics card use the backup, and now I can get it to try reading the files off of my USB drive (I have a different version of the BIOS on there that I'm trying to use) but it keeps saying "Reading failed". I tried reformatting the USB to FAT32 twice but it still gives me Reading Failed.

    Oh, and I tried removing the USB drive and it's still "reading failed"ing at me.

    Edit: Seems to be fixed now! I ignored the reading failed message as it only happened if I tried to use the mouse, so I just navigated the menu with the keyboard and reflashed the BIOS and everything seems to be okay.
Ask a new question

Read More

Chipsets BIOS Computer Boot Motherboards