Sign in with
Sign up | Sign in
Your question

Asus p8Z68 BIOS recovery

Last response: in Motherboards
Share
December 1, 2012 7:51:20 PM

This is a long one.

I have been trying to install Windows 8 on my machine (p8Z68-V PRO, i7-2600K) but it just doesn't work. It boots to the setup and crashes in the amount of time it took you to read this sentence. Real annoying.

I did research about the requirements and what could possibly be preventing the installer from even opening and I got to messing with my BIOS. I know what I am doing, I was just "simplifying" my board - disabling fancy features like hyperthreading and speedstep and setting my SATA back to IDE (just in case) but nothing worked.

So then I tried to update my BIOS. I downloaded the newest one from Asus' P8Z68 drivers page ( bahblah.ROM ) and went into EZFlash 2, selected, and clicked install. The little bar at the bottom did its thing in a reasonable amount of time and everything looked good.

But then on restart I get 2 long beeps of dread ( indicating a BIOS failure I guess, the manual doesn't say ) and a message telling me that I have the joy of finding myself in BIOS RECOVERY MODE.

It tells me to insert the "Asus Support DVD", which I'm not sure but I hope is the disk that came with the board. It doesn't actually say support disk anywhere on there but whatever. I insert it and restart and nothing happens. Is not big surprise, frankly.

It also tells me to put the BIOS on a FAT 32 USB drive. I do so, renaming the ROM to the proper name and restarting. Two beeps, but this time no message. However, I leave it running for 15 minutes and nothing happens.

No USB = recovery message.
USB = no message.

Can anyone tell what I am doing wrong? Short of losing one or more limbs this is the worst thing that could have possibly happened at this moment. I kind of need this running by monday at MOST. And that is the absolute worst case scenario.
December 1, 2012 8:18:48 PM

Sorry for double-post but the last one is too long already. I forgot to mention:

I removed all of the PCI components of my motherboard ( 1 network, 1 sound, 2 gpu ) and the beeping stopped. The USB/recovery message behavior persists, though... I assume plugging the components back in will bring back the beeps.
m
0
l
a c 150 Ĉ ASUS
a c 557 V Motherboard
December 1, 2012 8:33:18 PM

Hi, Have you tried clearing the CMOS (unplug the power cord and remove the CMOS battery for few minutes)? Not sure though if it will solve the issue.
A simple solution would be ordering a BIOS chip programmed with the latest version and replace the board's one. But probably not until Monday.
Test the board with a minimum configuration (one RAM stick, only the DVD drive connected, keyboard and mouse) and try clearing the CMOS.
m
0
l
Related resources
December 1, 2012 8:53:47 PM

Thanks for responding.

I did try to clear the CMOS earlier by removing the battery and it had no effect. I tried again with your suggestion of a minimal boot and unfortunately no change. I also tried shorting the CMOS resetter.

I think the problem is that I am simply doing some recovery thing wrong. What I really want to know is what Asus means by the "Support CD". If it is not the disk in the box then where can I download it from?

I also want to know if I have the right BIOS file ( it is the version prior to the current, from Asus' website ).
m
0
l
a c 150 Ĉ ASUS
a c 557 V Motherboard
December 1, 2012 9:01:40 PM

The Support CD is the one that comes with the motherboard. If you check the files on it, you should find the .ROM file with the original BIOS version.
Theoretically the BIOS recovery should work.
The original BIOS version is on a thin sticker on the motherboard. (usually, near the 24 pin power connector - the one with a barcode). The last separated 4 digits stand for the board's BIOS version.
But now the recovery might look for the new BIOS file. Try saving on the FAT formatted USB stick the new BIOS file renamed as on the board's DVD. Connect the stick to a USB 2.0 port.
m
0
l
a c 118 Ĉ ASUS
a c 468 V Motherboard
December 1, 2012 10:37:26 PM

most bios recovery is looking for the bios file on the root of a cd or usb stick. i would try download the newest bios again onto a cd and see if it works.
m
0
l
December 3, 2012 4:57:49 PM

Ok, I have tried with 3 different BIOS versions now: The newest, the original, and the one I had before the update. None of them seem to have worked, but I am suspecting that the USB stick could be a problem. I tried another stick though with the same results.

Every time I feed in a "new" BIOS (different from the version it has at this point) it powers on for a few seconds, and the restarts, as if it actually did flash the BIOS and is about to start up, but no luck.

I noticed that the CPU's POST light stays on all the time, now. Also, if there is no VGA connected the VGA light will activate too.

I ordered a new BIOS chip anyway, and I will survive until then...
m
0
l
!