Sign in with
Sign up | Sign in
Your question
Closed

Why is my windows 7 extended desktop flickering

Last response: in Graphics & Displays
Share
September 3, 2011 2:43:09 PM

I am desperate for help here.

I have a brand new system the I just built using the Gigabyte GV-R6750C-1GI video card running Windows 7 Pro 64-bit.
Everything was fine until I extended my desktop across to the 2nd monitor. The 2nd monitor flickers either a black bar across the top or bottom of the screen or just flickers a mirror stamped image just slightly offset of itself.

I have worked with Gigabyte Tech support and was told to update my drivers which I have the latest Catalyst driver installed and the problem did not go away. Gigabyte told me I must have a defective card so I RMA'd my new card and received a brand new one as replacement from my vendor. The same exact problem with the new card. I then uninstalled the AMD/ATI drivers & catalyst software, rebooted, reinstalled and rebooted again. Same problem. I then rolled back the driver to my Dual Samsung SyncMaster 2433BW monitors to an older XP/VISTA driver and same problem.

I have changed some misc settings on the 2nd monitor in the Catalyst software and with any change at all, doesn't seem to matter what the change is, the problem moves to the 1st monitor. With any other change, it moves back to the 2nd. It seems to flip flop back and forth with any video configuration change. Never both monitors at the same time, only one at a time has the trouble.

I'm an IT professional here and I can't figure this out. My best guess is that there is some inconsistency with this video card and my monitor but what it is, and how to fix this problem aside from buying 2 new monitors and a different video card, I have no idea. There has got to be a way to fix this. I have read over 50 threads around the net with people having the same problems and they only things that are in common are ATI Video Chips and Extended Desktops.

I would be very thankful for someone to solve this problem for me since myself nor Gigabyte has any answers.

Thanks.
a b U Graphics card
September 3, 2011 2:56:07 PM

It is highly unlikely to get a lemon card a second time. Therefore the first thing I would do is switch cables and double check they are secured correctly. More to the point, I would swap the monitors around, connect the right to the left and visa versa.

If it's not the cable, check the refresh rate. If the refresh rate is also right, the last thing I can think of is to check the monitor menu itself. Some monitors have odd options in their menus that can really mess things up, setting it back to factory defaults should help.
Score
0
a b U Graphics card
September 3, 2011 3:00:28 PM

hundreds or thousands have this problem im one of them.
some say to "STOP OVERCLOCKING YOUR CARD", some say you need to do crazy registry and hidden video card setting files edits.
all you need to do is go into your catalyst control center, click on preferences, click on advanced mode, click on video( its on the left), click on video settings,
you will see a lot of settings with green or red slider switches on the left of them. change all the sliders to red.
im not sure which one fixes it but i didnt notice any problems with them all off. it fixed it for me.

i hope it fixes it for you
Score
0
Related resources
September 3, 2011 3:56:58 PM

The cables on the monitor are good as my old computer did not, nor does it have this problem when I move the cables from newer to the older card. I have switched the cables around previously as well. These monitors will work either DVI or VGA and my card is DVI. I am using quad shielded DVI cables which are of the highest quality.

I do not think I had a bad card to begin with, but Gigabyte told me that it must be the card so I got a replacement. I am with you, I do not think you can get 2 bad cards in a row. Although possible, very unlikely.

I have checked the clock settings in the Catalyst control center. I am not an over clocker, in fact I have been known in the past to slightly under clock my computers as reliability, cooling and energy savings are always top on my list, however this computer is running 100% factory recommended settings in the BIOS for CPU, Memory, Video etc. As far as the catalyst settings are concerned, I am running factory defaults on all video settings.

I have spoken to Gigabyte about the AMD Overdrive options in the AMD Vision Engine Control Center and they told me no matter how you set them, it does not change anything for overclocking. The AMD Overdrive slider is set to Enabled which all it does it allow further changes to potentially overclock but does not by itself overclock anything. I have turned all the AMD Overdrive for both CPU & Graphics and set them to disabled and no changes there which makes sense to what Gigabyte has told me. Under Performance, Graphics Overdrive the box to select Enable AMD Overdrive is not checked so there is no over clocking going on on this card. The CPU clock settings are set to factory default at 740mhz, Memory clock 1200mhz and Fan Control is set to Auto. Current values are: GPU Clock 400MHz & Memory Clock 1150MHz.

GPU temperature is running at 50 degrees C with auto fan control and the system board is running at 38 degrees C. CPU runs at 38 degrees C with fan set to CPU variable control.

I am not a gamer, just use your basic business applications on here with video editing which I have not yet done on this computer since it was built as I had not installed that software yet.

Basic computer configuration is as follows:
Gigabyte Motherboard: GA-990FXA-UD3
AMD Phenom II X4 955 Black Edition Deneb 3.2GHz Socket AM3 125W Quad-Core Processor HDZ955FBGMBOX
Western Digital Caviar Black WD1002FAEX 1TB 7200 RPM SATA 6.0Gb/s 3.5"
CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 15000) Desktop Memory Model CMZ8GX3M2A1866C9B
Antec Sonata II Case with 500W TruPower Powersupply, 120MM Case Fan running on the Medium speed (Slowest was too slow for cooling & highest didn't change any temperatures inside the box)
And of course the Gigabyte Graphics card: GIGABYTE GV-R675OC-1GI Radeon HD 6750 1GB 128-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card

Windows 7 Pro x64 & a Sony SATA Optical Drive

Nothing fancy here, just a plain Jane bare bones PC.

I'm all ears for any suggestions. At this point, I'm willing to try just about anything.
Score
0
October 13, 2011 4:05:54 PM

Same problem. Same card, I've had two. I've still got the problem.

I'll have to get an nvidia board.

Nothing I do solves it. Changed monitors, cables.

Problem doesn't exist in single monitor, only extended.
Score
0
October 28, 2011 12:44:36 PM

any updates on this? would like to know, as im also looking into that card..
Score
0
November 4, 2011 6:28:46 PM

I have the exact same problem with the same video card and same setup (ie: dual monitors, extended desktop). Problem doesn't exist on a single monitor, but flip flops from one to the other throughout the day with nothing specific being done when the swap happens...

Very bizarre. Any updates by chance? Was going to call Gigabyte this afternoon for support, but now I'm thinking it's a waste of time...

Note: PC, monitors and video card... everything, is brand new just this week.
Score
0
December 11, 2011 8:38:54 PM

I too am having problems with screen tearing and "ghost windows" on my desktop while in extended. If I change settings, it just switches to the other monitor. This is very frustrating. Additionally, while running in Crossfire with Dual XFX Radeon HD 6750's, it will happen to my single monitor. I tried having my monitors plugged into seperate video cards and only using crossfire (disabling the other monitor) when gaming, but the problem still occurs...

System Setup:
Gigabyte GA-990FXA-UD3 Rev 1.1 Motherboard
AMD FX-6100 Zambesi 3.3GHz AM3+ 95w Six-Core Processor
16 GB Patriot Viper Xtreme DDR3 1866 (Running at 1600) Memory
OCZ Vertex 3 60GB Sata III SSD (OS only)
Seagate 7200 RPM 1.5 TB HHD
Corsair H80 High Performace Liquid CPU Cooler
2 XFX HD-675x-ZMFR Radeon HD 6750 1GB 128-bit GDDR5 Video Card (Crossfired)
2 ASUS VH236H 23" Full HD Widescreen Video Monitors

I've tried running only one screen, running the monitors on seperate cards with crossfire disabled... no matter what, I experience some major screen tearing occasionally and it eventually locks up.

I've tried using the DVI and the HDMI ports with the same results...

If anyone figures this one out, please post the solution.
Score
0
December 18, 2011 12:27:47 PM

Ok LISTEN UP! I found the solution while scouring the internet yesterday after I decided I am either finding a solution today!... or returning the cards...

Here it is. Ready?

Go to Phyxion.net and download Driver Sweeper.

Go to the AMD website and download the old 11.8 AMD CCC (Catalyst Control Center). The WHOLE Suite and the coinciding application profiles.

Uninstall your current application profiles and restart your pc.

Uninstall Your current AMD CCC and all video drivers and restart.

Install driver sweeper and remove the remaining AMD video drivers and restart.

Install AMD CCC 11.8 and the coinciding application profiles and you should be fixed.
Score
0
January 9, 2012 7:42:50 AM

techguy2011 said:
Ok LISTEN UP! I found the solution while scouring the internet yesterday after I decided I am either finding a solution today!... or returning the cards...

Here it is. Ready?

Go to Phyxion.net and download Driver Sweeper.

Go to the AMD website and download the old 11.8 AMD CCC (Catalyst Control Center). The WHOLE Suite and the coinciding application profiles.

Uninstall your current application profiles and restart your pc.

Uninstall Your current AMD CCC and all video drivers and restart.

Install driver sweeper and remove the remaining AMD video drivers and restart.

Install AMD CCC 11.8 and the coinciding application profiles and you should be fixed.


Was this the correct fix? I am having the same issue with Crossfire'd Gigabyte Radeon HD 5830 cards and 2 23" 1920X1080 (native) displays with Catalyst 11.12 drivers. When I switch to Eyefinity, both monitors work great...no flicker. Thanks for the help in advance!
Score
0
January 9, 2012 7:44:14 AM

farrengottu said:
hundreds or thousands have this problem im one of them.
some say to "STOP OVERCLOCKING YOUR CARD", some say you need to do crazy registry and hidden video card setting files edits.
all you need to do is go into your catalyst control center, click on preferences, click on advanced mode, click on video( its on the left), click on video settings,
you will see a lot of settings with green or red slider switches on the left of them. change all the sliders to red.
im not sure which one fixes it but i didnt notice any problems with them all off. it fixed it for me.

i hope it fixes it for you


farrengottu,

Tried this fix, restarted the system...flicker on 2nd monitor persists. Thank you for the try though! ;) 
Score
0
!