Sign in with
Sign up | Sign in
Your question
Solved

Asrock Z77 Extreme4 3TB HDD problem

Last response: in Motherboards
Share
December 4, 2012 11:13:55 AM

Hi all,

thanks for viewing my post.

My z77 extreme4 mobo uefi bios is seeing my 3TB Seagate HDD as 2TB and 700GB. And I cannot merge those two in windows install. What do I do? Aren't Mobo's with uefi bios suppose to be able to see 3TB HDD's as single 3TB HDD?

UEFI BIOS is seeing as 3000GB but when I start to install Windows 7 x64 bit, the windows install sees the HDD as 2TB and 700GB!

What do I do?

please help
December 4, 2012 11:35:54 AM

There should be a driver on cd you got with your motherboard it should allow you to see it as 3TB and if its not there check asrock driver download section for your motherboard.
m
0
l
a b V Motherboard
December 4, 2012 12:42:41 PM

What format did you pick to initialize the disk? I think it has to be gpt for discs over 2TB.
m
0
l
Related resources
December 4, 2012 1:18:44 PM

Yes I do believe NTFS should be able to do it but if your having issues GPT should work too.

Edit The maximum size for a NTFS partition is 2TB. Divide the drive into a 2tb and 1tb partition.
m
0
l
December 4, 2012 1:20:43 PM

Yes you have to format the drive as a GPT file system for the Os to see the full 3TB.
NTFS wont do it, there will be an option in the bios UEFI for a Gpt type format and partition option.
m
0
l
December 4, 2012 2:14:11 PM

I didn't see that option, can I do the formattin from the BIOS?
m
0
l
January 9, 2013 4:32:43 PM

I' m not sure if you solved this problem, OP, but I followed the other poster's fix by right clicking on "Computer" on the right side of the start menu and selecting "Manage". Once in the Computer Management window, go down below "storage" on the left side and choose "Disk Management". When you see your 3TB drive, right click on the area to the left of it (says "Disk 0" or "Disk 1") and choose "Make GPT drive". You'll see the partitions removed and a full drive. Then right click on the disk space area (black line over it) and choose "New Volume". Then go through the setup to make partitions, assign driver letters, etc. Hope that helps!
m
0
l

Best solution

a b V Motherboard
January 10, 2013 6:30:52 AM

techstud's solution should work if you are just adding the drive as a data disk. In that case the following alternatives should also work.

You can use diskpart's "clean" command (http://www.sevenforums.com/tutorials/52129-disk-clean-c...) or the QuickWipe option in HDDGuru's Low-Level Format tool (http://hddguru.com/software/HDD-LLF-Low-Level-Format-To...).

Make sure you clean the right disk. Then when you open Disk Management, it will automatically sugest to initialize the disk as either MBR or GPT. For 3TB or more you will have to use GPT.

If you want to install Windows on the 3TB disk, then you need to choose another route. The Windows installation DVD should have a folder called "EFI" in the root. When you start the system, press F11 to get a boot menu. It should list something like UEFI: DVD (model name of your DVD drive). If you choose this option to boot from the installation DVD, then the disk should automatically be initialized as GPT and you can use the full 3TB.

If it does not work, then try cleaning the disk first with one of the previously described methods.
Share
February 16, 2013 3:25:24 PM

Well, thank you all for your replies! I finally figured it out,

All I needed a Windows 7 with that UEFI boot thing available, the current one I have doesn't have that so that was the main issue after I converted the disk to GPT

1 friend of mine lent me his Windows 7 that had UEFI boot option available but his was a pirated windows so I just decided to use the Seagate Diskwizard to unlock the remaining HDD space and installed my own Windows 7 on the MBR type HDD. No difference.

But Thank you all!
m
0
l
February 16, 2013 3:26:09 PM

Best answer selected by muujig612.
m
0
l
March 12, 2013 7:30:04 AM

sorry to bump an old thread, but I think I could use some expert's help on this.
So my problem is exactly what the OP experienced . I know that I could easily use ASRock 3tb unlocker to unlock the missing part of the drive.
but that doesnt really help me because I want 2 partitions configuration (200gb for C -for the windows- and 2.5tb for D, the unlocker only lets me to make 3 or more partitions configuration)

so I tried the UEFI boot thing, I finally got my hands on a copy of windows 7 with efi folder (it is pirated ver. just to see if it would work) I downloaded it to my flash drive, and made it bootable. On POST I pressed F11 and I found the uEFI blah blah blah listed on the option. I selected it and hit enter but nothing happened. tried several time but still no luck what so ever. I thought that the problem was my flash drive, so i burnt the windows to a dvd. this time no UEFI on boot selection, but AHACi: ..... (there were two of them, my hdd and my dvd drive)
I chose the dvd and hit enter, it successfully booted from the dvd, but it was still giving me that 2tb and unaccessible 7gb configuration.
I flashed my bios, and still nothing.

So, what do you guys think I should do?

my rig:
3570k
z77 ext4
hd7970 vapor x
2x4gb corsair vengeance 1866
wd red 3tb
naxn 750w
m
0
l
a c 973 V Motherboard
March 13, 2013 5:42:18 AM

Please start a new thread.
m
0
l
!