Bad colour on new screen , PLEASE HELP

Hey , i just got a bx2331 23 inch samsung hd 1080p monitor {runs at 60 Hz}

When i was playing battlefield i noticed the bad coulour quality of the muzzleflash from the gun , i went into my monitor settings and found out that if i put the response time to normal instead of fastest the flash looked a lot better.

When i was playing mass effect 2 i noticed greenish ring around the screen they were faint but visible.

{normaly there would be a light to dark colout transition there}

Also noticed that in the standard windows wallpaper {especialy near the edges of the screen} the transisions in colour {blue - light blue} are bad aswell. :(

Today while i was skyping with someone i noticed the VERY ugly transistion from blue to black in the skype background , it had ugly lined and green blobs , its not smooth

I also notice it while playing crysis , when i look at the night sky in game the transition between ligher areas and darker ones is in steps and not smooth.

I hate tried resetting the monitor and it didnt work, please help me fix this problem

{it could also be a GPU problem , driver settings or that stuff}

by the way this did not happen to my older benQ 19 inch 5:4 from 2005 lcd screen , the coulours on the screen werent so good but the transitions between them were alot better

Please help me and thanx in advance.



Specs and drivers:

Newst 280 nvidia drivers

Windows 7 ultimate 64 bit :sol:

intel 2500k , not OC''d

gtx 560TI msi twinfozr II

4gb vengance ram

750 watt corsair HX psu

32 bit RGB setting

1920 x 1080 80 HZ


Need more info to help me ? , post what you need and i wil provide it

Again, thanx in advance
5 answers Last reply
More about colour screen help
  1. It sounds like the levels on your monitor are being crushed.

    First we want to make sure we start with everything baselined. To start with, I am sure that you know to connect the monitor via digital connection, in other words DVI or HDMI. As you stated you tried resetting the settings on the monitor which is a good first step. You should also restore the default color settings in the NVIDIA control panel just in case. Also to confirm, you have the display set for 1920x1080 60Hz 32bit?

    Although most monitors do not ship with an accurate calibration the default settings should at least be usable for most people. It could be a dynamic contrast setting on the monitor which is causing your problem. Look for any dynamic brightness/gamma/contrast setting and try disabling them to see if the problem goes away. I believe for your monitor they are the "magic" settings.

    If you suspect that the issue is with your video card you can try connecting your monitor with a different video card or better yet a different PC.
  2. Thank you for the reply !

    I checked the settings im running at 1080p native it says BUT , it seems to think my monitor is a hd tv since it says this : HDMI-HDTV {audio disabled}

    I connected it like this GPU - DVI-----------------------------HDMI - monitor

    There are a couple of magic options yes , magic contrast,brightness,colour when i turn them off the screen just looks duller and it still has the problem

    Photo of settings / link if the picture does not show up:
  3. On your monitor, reset to factory defaults once more. Then in the menu scroll down to "setup" > "mode". Is it set to AV or PC? Change the setting to PC if it isn't.
  4. its at Cp and i reset it again and nothing hapopened
  5. Don't know if you're still troubleshooting this issue. At this point I would test the monitor with a different computer to see if the problem remains. You may have a lemon.
Ask a new question

Read More

Nvidia Graphics