Help! GA-Z77-D3H bios setup question

I just assembled my first build with the following components:

CPU - i5-3570k
Mobo - GA-Z77-D3H 1155 LGA
RAM - G.skill ripjaws 1600
HDD - WD caviar black 1TB
PSU - Corsair cx430
case - Zalman z9 plus

i just put everything together and plugged in a VGA connected monitor, hoped for the best, powered on, hit DEL key, and it tried to go to the 3D bios setup I believe but the picture came in blocks and would come in more as I moved the mouse around but I couldnt do anything, tried restarting several times now and im not getting anything now. any idea what to do??? :sweat:
2 answers Last reply
More about help bios setup question
  1. I emailed Gigabyte they said,

    Please check the following:

    1) Remove CMOS battery for 10-15Mins.

    2) Assure both ATX-24PIN and ATX12V-8PIN power are connected properly to the motherboard, (see user manual page 5-7 for ref).

    3) Check make sure front panel power switch is connected properly (see page 24-30 for "F Panel header"

    4) Test with motherboard, CPU and 1 stick of memory module only.

    5) If problem persists, please test the motherboard outside of the case to prevent power shortage.

    I've tried all but number 5. Again, the first time I booted i got the 3d bios screen but it was glitchy and i couldnt click anything,

    Everytime since, if i dont press anything i get: "No bootable device. Please restart with bootable device"
    If i hit DEL key after booting i dont get anything but a very thin white line, like 1 pixle in height and its about an inch long at the very top of the screen about an inch from the side, that blinks every other second.

    Does anybody know what i can do?? flash bios, short cmos, could it be the monitor? i have a new one coming today that uses DVI instead of VGA.
  2. Well, after MUCH frustration I've got it settled. It was the monitor! For anyone that may want to know I was using a Dell CRT monitor via VGA cable, my new monitor is an LED LCD via DVI cable. idk why that made the difference but i plugged this one in, hit DEL, and it popped right up flawlessly.

    It'd be interesting to hear if anyone else had this problem or know's why this happened.
Ask a new question

Read More

Chipsets Motherboards