Corsair Mem Not Running @ 1600MHz

Hi Guys,

Today i got my new 2 kits of 4x2GB (Total 16GB) Dual Channle Corsair Vengeance RAM. But its not running on 1600MHz. Its working fine on 1333MHz. But when I set manually to 1600MHz my system doesn't boot up and keeps restarting. I have updated the latest BIOS but not worth it.

Below RAM I Bought:
http://www.corsair.com/memory-by-product-family/vengeance/vengeance-8gb-dual-channel-ddr3-memory-kit-cmz8gx3m2a1600c9r.html/

My Spex:
Processor: I7 3770K
RAM: Corsair Vengeance DDR3 8 GB (2 x 4 GB) PC RAM (CMZ8GX3M2A1600C9R)
MoBo: Asus Maximus V Gene
Graphics: Inbuilt

PLEASE HELP IN THIS.
4 answers Last reply
More about corsair running 1600mhz
  1. Try to use XML memory profile in the bios and use the default profile.

    If that doesn't work rma it.
  2. I tried to find XMP, But there is an auto mode. I guess this is it only.
  3. Have you tried your MB manual to find XMP profile also have you tried Mem test?

    If mem test fails your memory is corrupted and its RMA time
  4. Memtest is gud....passed 3 times...

    And i googled this matter and Google Guru says that turn off the Turbo mode and it works...But i stuck on 3.5 GHz and it does not boost itself now.
Ask a new question

Read More

Memory RAM Corsair