Sign in with
Sign up | Sign in
Your question
Solved

[Solveld] Asus sabertooth 990fx does not post

Last response: in Systems
Share
November 2, 2011 10:08:26 PM

Ok so i just got finish building my new rig. But when i power it up it does not beep and there is no display

I have Asus Sabertooth 990FX mobo

Amd Fx 8120 cpu

8 gig Corsair Vengeance Ram

Asus EAH6850 Gpu

and Corsair HX850W Psu

Everything is powered and there is no led lights on, on the mobo to indicate a problem. So I'm completely lost right now

when i first turn it on the cpu led comes on for a bit a second, then goes off, other than that just the power led is on.I have 2 PCI-E connector connected to the gpu, and i have the EATX12V connected as well, so it does not beep at all, I tried clearing the CMOS as well but that didn't work either

Best solution

a b Ĉ ASUS
November 2, 2011 11:54:54 PM

I'm going to take a wild guess that your mobo does NOT have the newest BIOS which is required for the AMD FX CPUs. Go to the Asus website and check what BIOS is required because your mobo probably shipped before this BIOS was installed on production mobos. If you have or can borrow a Phenom II CPU, you'll be able to easily update the BIOS as the mobo should boot with a Phenom II CPU.
Share
November 3, 2011 4:14:38 AM

ur right it doesnt, and i do have a phenom ii cpu, but its really old so i doubt that it would work on my mobo

**Edit**

Ok i tried my old Phenom II and it was able to work, it would still crash b4 i load in windows, though, but i was able to dl the bios update using my laptop and install it using ez install so now it post with my FX 8120 cpu
m
0
l
Related resources
November 3, 2011 5:12:40 AM

Best answer selected by Gungrave223.
m
0
l
November 5, 2011 7:19:21 PM

Gungrave223, Sabertooth 990FX with your FX processor seemed to be completely "dead" ? It wasn`t possible to get even to BIOS in order to upgrade it ?
This makes me worried cause I`m receiving mine 990FX and FX-8120 on monday and I don`t have any earlier AM3 processor or anybody to borrow from neither...
m
0
l
November 5, 2011 10:56:26 PM

Got the same mobo and cpu as well. I received my kit yesterday and I seem to have exactly the same issue. Off down the local computer store in the morning to buy the cheapest AM3 CPU I can find so I can update the bios!
m
0
l
November 5, 2011 11:12:05 PM

Don't buy a CPU for that. Demand ASUS or the store to supply you with a working product instead...
m
0
l
November 6, 2011 1:58:45 AM

I have a very similar setup (same mobo and processor and psu) and the same problem with no lights and no screen display except my new build was running for a good week just fine and then all of a sudden locked up and wont reboot. Any ideas? Cant see it being a bios thing since it was already working. Tested psu and graphics in another computer but could test the ram or cpu.
m
0
l
November 6, 2011 2:29:53 AM

Ya its differently needs a bios update before it works with Amd FX series cpu. I don't know why Asus would do something like sell mobo that doesn't support the cpu it was built for right off the bat, I was luck that i had a Phenom II cpu from my last built
m
0
l
November 6, 2011 2:52:55 AM

But why would it be a bios update if the system was running just fine and now all of a sudden wont post?
m
0
l
November 6, 2011 3:16:17 AM

Not sure, did you have the FX cpu in it originally?
m
0
l
November 6, 2011 3:43:59 AM

yep, its the only cpu thats been in it, worked fine for a week. Went in the other room last night for about 30 mins and came back to a black screen, like the monitor had turned off, wouldnt wake up and had to hold the power button to turn it off. Turned it back on but it wont do anything. cpu light flashes but no other lights come on or sounds made.
m
0
l
November 6, 2011 3:46:40 AM

did he cpu light stay on?
m
0
l
November 6, 2011 3:48:58 AM

just comes on for a second then goes out, then the ram light blinks once really quick and thats it
m
0
l
November 6, 2011 3:53:16 AM

then it probably is the bios. cant explained why it suddenly stop working, but that was the problem that i was having
m
0
l
November 6, 2011 3:59:06 AM

well now i have to figure out how to update without another AM3 cpu
m
0
l
November 6, 2011 6:40:51 AM

Quite strange, Sabertooth 990FX which came out earlier this year should not support FX`s right out of the box, the first BIOS (according to asus cpu support page for this board http://www.asus.com/Motherboards/AMD_AM3Plus/SABERTOOTH... ) suppotring FX`s is 0705.
I am wondering what BIOS will be installed on my mobo ... boards which left ASUS factory after 11 October should have newer BIOS installed but I do not think I may get one of these. Is there any information about BIOS version on the box ?
Was any one of you lads able to boot up to BIOS with FX and some bios version lower than 0705 ?
m
0
l
November 7, 2011 7:18:10 PM

I received my 990FX with pre-installed BIOS 0705 :-) It work like a charm :D  Didn`t have to reinstall my Windows ... that`s strange because I though it will be a must with new MOBO and completely different setup (Intel previously)
m
0
l
November 8, 2011 11:25:12 PM

subuk said:
I received my 990FX with pre-installed BIOS 0705 :-) It work like a charm :D  Didn`t have to reinstall my Windows ... that`s strange because I though it will be a must with new MOBO and completely different setup (Intel previously)




where did you get your board from? i want to wait till xmas to get this board ... hope bios is standard 0705 or higher by then.
m
0
l
November 9, 2011 2:55:55 AM

scud_75 I bought it in here in Poland for 116 GBP. I was looking for a production date or some code where month/year could be included ... but there`s nothing like that. There are some ASUS codes but probably only known to them I gues :D  The only reasonable way is to check if certain mobo you`re going to order has higher S/N than somebody`s who already got one with preinstalled 0705.
m
0
l
January 29, 2013 2:00:41 AM

Gungrave223 said:
ur right it doesnt, and i do have a phenom ii cpu, but its really old so i doubt that it would work on my mobo

**Edit**

Ok i tried my old Phenom II and it was able to work, it would still crash b4 i load in windows, though, but i was able to dl the bios update using my laptop and install it using ez install so now it post with my FX 8120 cpu


im having the same issue i have no display i downloaded the file from asus onto a diskdrive do i need anything else?
m
0
l
!