Sign in with
Sign up | Sign in
Your question

New HDTV Input Lag issues! HELP!!

Last response: in Graphics & Displays
Share
September 5, 2011 6:34:34 PM

So I just purchased a LG 42LK520 this week and I am having some serious input lag issues. I am using it purely as a computer monitor.

I have tried switching from HDMI to VGA, still have input lag.
I turned the TV onto "Game Mode", still have input lag.

My question is that I would like to know of course is there any way I can get rid of the input lag on this particular TV. I cannot seem to find anything online on this exact TV and how to fix it so I am hoping I can find someone else with this TV that fixed it.

My next question would be that if I cannot fix the input lag on this TV, I will probably send it back and get a refund and purchase a different HDTV. I want either a 40-42 inch TV so any recommendations for the best HDTV that is that size without input lag for gaming would be most appreciated.

I really hope there is a solution because this is a magnificent TV.

Thanks for your time.

More about : hdtv input lag issues

September 5, 2011 6:54:10 PM

hold on.. you using vga to hdmi???
you should try dvi to hdmi.... see if the problems solves. in amazon those kind of cables are cheap, but careful don't buy junk
m
0
l
September 5, 2011 7:10:16 PM

Im using a VGA - VGA not an hdmi cable. I tried HDMI but it has much more lag with HDMI
m
0
l
Related resources
September 5, 2011 7:17:07 PM

Is the cable over 5 or 6 feet ?
m
0
l
September 5, 2011 7:17:56 PM

ok it has something wrong with your video card..
what video card you have?
m
0
l
September 5, 2011 7:23:30 PM

spentshells said:
Is the cable over 5 or 6 feet ?



in my practice i used over 15ft cables it is not an issue
m
0
l
September 5, 2011 7:27:06 PM

First, check to see whether your TV has a Game mode--basically, a display mode that turns off postprocessing routines at the cost of a slight reduction in image quality. You might have to muck around in the manual to figure out exactly what it does--some manufacturers incorporate an Overdrive mode that may actually increase input lag.

Next, turn off as many other video-processing options as you can. Each manufacturer tends to identify its features with different acronyms such as DRE or 3DNR; try turning them off and seeing whether your lag improves.

If you use HDMI or component cables to connect your setup to your display, try using VGA instead. Display manufacturers sometimes restrict the postprocessing functions to HDMI or component video inputs, leaving the VGA input untouched. If your device doesn't have a proprietary VGA cable, you could try using an HDfury, though we haven't tested it in-house yet.

Finally, some apps and games have their own built-in latency calibration options. Both Rock Band and Guitar Hero, for example, include lag calibration functions as menu options to help you adjust the game's timing and to minimize lag. If these games are incorrectly calibrated, the faulty setting could be causing input lag, so be sure to test the settings before you try to play that fret-melting song.
m
0
l
September 5, 2011 7:39:12 PM

That was copied and pasted from several other threads I have already read. As i said in my first post I have a VGA cable, and I already have it in game mode. My video card has ran other TV's just fine so it leads me to believe it is this particular model
m
0
l
September 5, 2011 7:45:55 PM

probably..
i don't know why it is in your case i have 55'' Led LG and works just amazing...
but try to play with tv and turn off everything possible. btw what video card you have?
m
0
l
September 5, 2011 9:06:03 PM

I have a HD 4890 so it is more than enough to run a tv like this
m
0
l
September 5, 2011 9:18:40 PM

that's true but sometimes ccc gives a hard time
m
0
l
September 5, 2011 9:33:11 PM

doesnt even use CCC anymore it uses AMD VISION Engine Control Center
m
0
l
September 5, 2011 9:36:53 PM

same crap...
m
0
l
September 5, 2011 9:37:25 PM

msi afterburner.. ;]]]
m
0
l
September 5, 2011 10:24:17 PM

depends on the quality of the cable, strength of the signal and also the signal receiver on the TV lag can be affected by these things maybe the old 4890 has had enough heat and has damaged the port you are using, or the reason you were given a 42 " tv is that it doesn't work right
m
0
l
September 16, 2011 2:29:58 AM

Anymore suggestions anyone? I have done all of this, none of it worked. The gfx card is fine, I have used several other tv's with no input lag before, its an issue with the TV itself. If someone knows a lot about this tv that could help me change some weird setting I cant find let me know.
m
0
l
a b x TV
September 16, 2011 11:48:31 AM

Not related to 4890.

Not related to cable specially if you are using HDMI. My longest HDMI is 25 feet and have no issues w/ it.

Go through the manual/feature of your LG tv to disable the 120HZ feature. It interpolates the video input and re-process it for better video quality. You don't need that for PC driven HDTV.
m
0
l
April 2, 2012 5:28:26 AM

just figured this out. apparently, when using the vga input on my 47lk520, there's a terrible amount of input lag if the computer is already outputting over the vga connection BEFORE you turn on the tv. if you turn on the tv first, and THEN set the computer to display to the 'projector', the input is gone almost completely.

you can also get rid of the input lag by switching it to another input, restarting the TV, and then switching back to the vga-pc input.

not sure why this happens, but it's repeatable.
m
0
l
!