Sign in with
Sign up | Sign in
Your question

What happened to my PSU

Last response: in Components
Share
February 3, 2012 3:07:25 PM

Hey guys,

I decided to go for an upgrade the other day an bought a Corsair TX650 and a GTX 560 ti 448. After installing both the system booted up and ran fine for about half an hour before the fan on the GTX started going crazy and then giving me a blank screen. I tried to reboot the system only to find the Corsair wouldn't power back up for me, lighting up the leds for a brief second before cutting out, so I switched my old PSU back in instead.

I've now also had to replace the graphics card with my old one since my old PSU isn't good enough to power it, and I'm just wondering what you think the issue might have been? I've been reading up and searching all night but couldn't find anything similar.

Is it a case of GPU overheating which for some reason buggered up the PSU, or is it simply a factory fault in the PSU?

Cheers!

Mike

More about : happened psu

a b ) Power supply
February 3, 2012 3:12:52 PM

Does the psu work at all now? Have you tried it with the smaller graphics card?
m
0
l
February 3, 2012 3:59:32 PM

Yeah I tried it with the old graphics card and still nothing. Pretty weird, I can't find anyone else with this issue.
m
0
l
Related resources
a b ) Power supply
February 3, 2012 4:45:41 PM

if the old card do not work that maens psu not giving power to her so rma psu if you could
m
0
l
February 3, 2012 6:40:53 PM

Ok so I used the guide, thanks Rugger. Based on what you guys are saying plus the hours I've spent trawling the internet I think it probably is a faulty PSU, which is odd since Corsair are so renowned for their quality and reliability. Anyway, I'm going to organise and RMA via the retailer.

Thanks a lot guys. Great community, very helpful!

Mike
m
0
l
!