Sign-in / Sign-up
Your question

Computer freezes while installing OS and intermittently afterwards.

Tags:
  • Homebuilt
  • Computer
  • Systems
Last response: in Systems
November 3, 2011 5:56:02 PM

As the title says, I've got a computer that just up and freezes intermittently. It happens when trying to install an OS, and if I actually get through the install, it still happens while using the computer.

The freezes are not temporary--control is not restored unless I switch off the power and turn it back on. Keyboard (PS/2) and mouse (USB) are frozen--cannot toggle Caps Lock or (obviously) move mouse pointer. There are no "beeps" when it happens from the mobo. There is no sound of activity coming from the drives (although if the LED for activity was on at the time of freezing it will stay on). If it was reading a CD (e.g. for install) the drive will not eject.

Mobo: ECS 755-A2
RAM: Kingston KVR400X64C3A (one stick)
CPU: Sempron 2800+
HDD: Hitachi Deskstar 164GB
GPU: GeForce4 MX 440 AGP 9x
Optical: HL-DT-ST GH22NP21

Been having problems with this one for quite a while.

Ran Memtest 86+ for 21 passes over more than 12 hours, no errors in the memory. Did NOT freeze up in this 12+ hours.

Ran Hitachi's Drive Fitness Test which reported no errors with the HDD. Did NOT freeze up during the test.

Several times when it's just frozen up, I restart quickly, go into BIOS, and check temps--everything is under 35 degrees.

Tried mucking around in BIOS settings (toggling APIC back and forth, changing various other settings, loading "Fail-Safe" defaults, loading "Optimized" defaults), and nothing seems to make it work.

It generally seems to happen within an hour of turning on the computer, but the other day I left it idle for about 20 hours and it was good when I came back--the day after, I left it idle for 10 hours, came back and it was frozen (ironically, according to the clock, 5 minutes before I came back to it).



If it's not memory (Memtest'd), not the HDD (Drive Fitness Test'd), and not the CPU temp (looked in BIOS after startup, temps under 35), what could be causing the freeze-ups?

I am fairly (but not completely) sure that it's not the PSU--this same computer was freezing up before, and I suggested to the owner to have whoever made the thing upgrade their VIOTEK 450W to something with a bit more power and a better brand. (He comes back with a VIOTEK 550W, heh.)


Computer is not mine; it belongs to a friend who has another friend who built it for his daughter.



Anyways, I'm a bit stumped. If someone here can point me in the right direction on what I should be testing, let me know.

--Sarteck

More about : computer freezes installing intermittently

November 4, 2011 1:34:37 PM

Optical drive bad perhaps. Can you tell when it freezes up, during read from optical or write to hdd? Do you have another optical you can try?
m
0
l
November 5, 2011 1:48:58 AM

I do not have another drive at the moment to test. I think I'll see if I can pull an old one from somewhere, though--I have a feeling that it's drive-related, too.

I cannot tell if it's read from optical or write to HDD, though. I -think- it might be on the write to the HDD, only because it seems to load CDs just fine (Kubuntu Live CDs, Memtest 86+, Hitachi Drive Fitness Test, etc.), but starts getting cranky when copying files over to the HDD. I don't know if that means the HDD is bad, though (if it does, I should just throw that Hitachi Drive Fitness test out the window, heh).



Recently, I've actually been getting an error when trying to install Kubuntu (before, it would just freeze up and not give me anything).

[Hardware Error]: CPU 0: Machine Check Exception: 4 Bank 4: b200000000070f0f
[Hardware Error]: TSC db2fbb66c2 {this one is different each time}
[Hardware Error]: PROCESSOR 2:20fc2 TIME 1320460290 SOCKET 0 APIC 0
[Hardware Error]: MC4_STATUS[-|UE|-|PCC|-]: 0xb200000000070f0f
[Hardware Error]: Northbridge Error (node 0): NB Watchdog timeout.
[Hardware Error]: cache level: L3/GEN, mem/io: GEN, mem-tx: GEN, part-proc: GEN (timed out)
[Hardware Error]: Machine check: Processor context corrupt
Kernel panic - not syncing: Fatal machine check on current CPU
Pid: 37, comm:scsi_eh_1 Tainted: G M C 3.0.0-12-generic #20-Ubuntu

and then lists a "Call Trace" containing a bunch of stuff.




Could this be caused by some kind of fault with the optical drive? I've had this error before with this same machine, but it went away when I changed in BIOS the CPU Clock from 800 to 400. (It's still at 400.)

EDIT: the HT_Speed, sorry, not the CPU Clock.
m
0
l
Related resources
November 5, 2011 12:48:34 PM

UPDATE:

After finally figuring out how to boot from USB (in my BIOS, I had to select it as the first Hard Drive to boot instead of selecting USB-FDD, USB-ZIP, or USB-CDROM in the boot priority), I began to install from a USB drive. The install reached about 80% copying files... then failed. :( 

I then took apart the entire system, leaving only the motherboard and power supply in the case. I re-seated the RAM. I took out the CMOS battery for a few minutes. I put everything back, tried to install from CD again.... and still it failed.

In a last-ditch effort before I went back to the guy I'm doing this for with my head hung in shame, I decided I'd just go ahead and try one more thing--put both the optical drive and the HDD on the same IDE cable, with the HDD as Master and the optical as Slave. (Previously, they were both on separate cables as Masters).

This.... worked?

At least I think so. There were some few-second freezes where the keyboard and mouse did not respond while the computer was copying files, but it actually got past the freezes. The files are now all copied from the CD to the HDD, and it's going through and fetching the "third-party software" from the Internet for the rest of the install. I'm HOPING the rest of the install and subsequent configuration will go as smoothly, and will update this thread later.

I don't understand why one cable would work whereas two cables would not, though. Anyone have a clue?



I'll post another update later today, hopefully with good news.

m
0
l
November 6, 2011 6:19:41 PM

The problem still occurs every now and then.

It seems to be when data is written to the hard drive, either by downloading from the Internet or copying from CD. I can't replicate it reliably, though--sometimes I can copy over an entire DVD of files with no problem, and sometimes it fails after a few hundred MB. Sometimes I can download a load of videos on BitTorrent and other times it freezes when using apt-get to download and install a small package.

I'm still playing with it and trying to find out exactly what is going on... The Machine Check Exception I get doesn't seem to get logged anywhere on the computer (or at least not in any file in /var/log), which I thought was a bit strange--don't they usually get logged to syslog?

Anyways, will post again when/if I get an answer.
m
0
l