Sign in with
Sign up | Sign in
Your question

Problems playing games on home built pc

Last response: in Graphics & Displays
Share
September 7, 2011 1:48:27 AM

Original Build:

Asus M4A87TD EVO
Phenom 955
Mushkin Ridgeback 1600 2x2gb
Earthwatts 650 PSU
Sapphire 5770 Vapor-X
Corsair H70

With this system, no matter what I did, the display driver would stop working then immediately recover within minutes of playing the game. If I lowered all quality settings to lowest, I could play the game longer but it would eventually happen. The picture freezes in vertical lines, but I can still see what's going on in the game somewhat, then within minutes the screen goes black. I then get the pop-up in the corner of the screen saying the driver failed. I spent hours and hours doing all the fixes other people have found because it's apparently a very common error with the 5770. Nothing worked. So I bought a new video card and upgraded the PSU since the Earthwatts apparently didn't put out enough amps for the Asus 6850. So I now have an OCZ 750 watt ZS series PSU and the 6850, BUT I STILL GET THE SAME ******* PROBLEM. I've never been able to get through a full 3dMark05 before. I've run prime95 for two days straight and everything is stable. Memtest, and the memory is fine. One stick of ram, both, different slots because it apparently works for some people. Whether or not I overclock, underclock, adjust voltages. I've been able to run a couple games with the 6850 (Zeno Clash and Battlefield Bad Company 2), as long as the quality settings are low except for the aa. It'll crash if the aa is off or low, but it'll work if it's maxed. It's not overheating, I haven't seen the video card to be more than 54 degrees when it crashes. Could it be that I got a bad video card twice in a row? Could it be other parts in the computer? WTF could it be? Should I just stick with Nvidia? PLEASE help me with this frustrating problem.
September 7, 2011 2:03:07 AM

since you have been through multiple psu's and vid cards, i think your motherboard may be faulty. And for the record your earthwatts puts out plenty of power for a 6850, a 380w earthwatts can run a 6850, so you kind of wasted money there. You should also run the hard drive manufacturers diagnostic utility to check for errors. Running Driversweeper may help also, maybe a fresh windows install.
m
0
l
September 7, 2011 2:05:02 AM

Anyway to check the motherboard, or just get a new one to test it? I have run driver sweeper and done a fresh windows install though.
m
0
l
Related resources
September 7, 2011 2:31:26 AM

The HDD is error free. Thanks for trying though.
m
0
l
September 7, 2011 4:01:10 AM

Test the card in another system, that will rule out the card. Sometimes that's easier said than done though :-)
m
0
l
!