GTX 570 Lagging?

So apparently this is what is happening, my games are lagging like shi* and my desktop feels sluggish. When I load it keeps on giving me the "Windows Error" message making me choose "Start Windows Normally" or something else. This happened after I installed a new CPU cooler the Noctua ND-14 and my fps is like 30-60 in left 4 dead 2 when it's supposed to be around 150-200, can anyone here explain what's going on? I tried uninstalling- reinstalling the drivers, the sound was muffled as hell too but I stopped using the Nvidia Drivers, I had BSOD a few times before....
9 answers Last reply
More about lagging
  1. Hello halodude23;

    What are you CPU temps like?
    If the cooler isn't installed correctly it might be overheating and throttling down to save itself from cooking.
  2. Install a fresh copy of windows
  3. WR2 said:
    Hello halodude23;

    What are you CPU temps like?
    If the cooler isn't installed correctly it might be overheating and throttling down to save itself from cooking.

    Hello, my cpu temp is 21* farenheit
  4. 21F? Really? below freezing?
  5. WR2 said:
    21F? Really? below freezing?

    Sorry, 21* celcius, I used the wrong measurement lol...Is there a solution for the problem?
  6. Even 21C under load doesn't seem right. I'd be expecting something closer to 45C with that cooler when gaming.
  7. WR2 said:
    Even 21C under load doesn't seem right. I'd be expecting something closer to 45C with that cooler when gaming.

    My bad, I wasn't being clear..
    Idle:21C
    For L4D2: 35 C
  8. And between the time GTX 570 was not lagging during gaming
    ... and when the GTX 570 started lagging - only the CPU cooler got changed? Nothing else changed?
  9. WR2 said:
    And between the time GTX 570 was not lagging during gaming
    ... and when the GTX 570 started lagging - only the CPU cooler got changed? Nothing else changed?


    I was lagging already when I reassembled the pc back together, I had a few BSOD and when I loaded it gave me the "Windows Error," also the whole screen slowly disappears like a white line coming down to clean up the words.

    Yeah, it's only when I installed the CPU cooler, replacing the Coolermaster 212+ and the GTX 570 is new, got it last week, replaced the GTX 460.
Ask a new question

Read More

Lag Components