Sign in with
Sign up | Sign in
Your question

Brand new amd pc built and wont boot bios! help?

December 8, 2012 5:34:39 PM

Case: Thermaltake Mid Tower V2

Motherboard: AMD Biostar A780L3C v.7.0

CPU: AMD Athlon II X4 640 Quad Core
Fan/heatsink: Thermaltake P/N:CL-P0503

GPU: Onboard: ATI Radeon HD3000

RAM: Kingston 4GB 1 PCS. 1600MHz

PSU: 150w Thermaltake TT450LN4NK

HD: Western Digital Blue 500GB
--------------------------------------------------------
Last night I put together my new PC with all said components and when I tried plugging into a monitor nothing showed up on the screen. No BIOS, no nothing. I tried breadboarding the whole thing three times making sure there were no shorts caused by touching wires or raisers. I took out the battery to reset the BIOS as well as reset the CMOS. I checked all the wiring and it is all correctly fitted and connected. I am able to turn on the computer without any beeping and the CPU fan, power supply and Hard drive all boot up but nothing shows up on the monitor. I looked and went over the troubleshooting list I found on a thread on this site and still nothing found. Any more suggestions on what I may need to do to get this PC up and running? could it be that I just have a defective motherboard?

!