Sign in with
Sign up | Sign in
Your question
Solved

Horizontal tears during gameplay

Last response: in Graphics & Displays
Share
September 7, 2011 8:27:01 PM

Hi, this is my first post and i dont use forums much so i hope im not posting in the wrong place or anything.

anyways, i have a problem with when i play games on my pc that if its a rather intense battle with lots of objects and fast moving things i see a single horizontal tear in the middle of the upper half of the screen. it doesnt do it if im standing still or if its a slow moving cut scene. it looks like the image has been sliced and slightly shifted over so its obvious that it doesnt line up. its not the whole piece above the line that is shifted, just a the tiny thin line itself. its not extremely noticeable and it doesnt seem to affect the game performance but i just built this computer a couple weeks ago and spent a lot of money buying good parts and i feel like this line is not caused by a performance issue but rather probably a setting or something. before anyone says to search the forums i have already spent hours searching and googling to no avail. i cant seem to find my exact problem. i have seen some people say that it might be the power supply isnt big enough but thats definitely not my case. i hear a lot of people say vsync but i didnt see a vsync option in the control panel for my graphics card. anyways here r my specs. i really hope someone can help me solve this. thanks in advance.

Coolermaster HAF 932
Corsair professional series gold 1200w PSU
ASUS p8z68-v pro
Intel i7-2600k @ 4.8Ghz
16GB Corsair Vengeance DDR3 1600 (cmz8gx3m2a1600c9)
EVGA nvidia gtx 580
corsair H60 cooling
Patriot Pyro 60GB cache (intel SRT)
western digital caviar black 750GB
2x ASUS 24x DVD burner
32LD450 LCD TV 4ms 60hz
a c 104 U Graphics card
September 7, 2011 10:04:10 PM

I have that with my 560 ti, you should yhink your system does that better yeah. Often you can switch vsync on/off in the settings of the game itselff.
In the nvidea pannel by "manage 3d settings" ( i translate from a Dutch os so maybe it's called different in English) you should have the option thread optimizer or something, it's like vsync i believe.
m
0
l
Related resources
a b U Graphics card
September 7, 2011 10:22:25 PM

to fix the problem download rivatuner (google it, should be first link), and run the d3doverider program included in the program. d3doverider forces vsync to be on in every game and your problem should go away.

Most games have a vsync option in game, but for those that don't this is the program I use
m
0
l

Best solution

a b U Graphics card
September 7, 2011 10:24:52 PM

Some games do not have an option for v sync what games are you playing? Im not super informed on nvidia cards but im sure there has to be a way to force vsync with the cards software. Alot of newer games will have a vsync option turning that on should solve the problem.

I read this on a forum

nVidia Control Panel > Advanced > Manage 3D Settings > Global settings, scroll down to the bottom > Vertical Sync > Select Force On

try that to force it. It is a better option to use ingame setting first then use the control panel second if you have to. Also do a game specific search. For instance I wanted v sync on badlands so I did a search and found out how to alter one of the games config files to turn v sync on even though there was no setting in game.

As stated above riva turner will work but if you can use the stock software to force v sync then that would be better than adding more software if possible. If this does not work post a specific game and I will try to see what I can find. :) 
Share
September 7, 2011 11:14:53 PM

thanks for ur suggestions everyone.

i was playing the force unleashed 2 when i saw it. i havent played any other games yet cuz i just built it so ill have to do that but force unleashed 2 doesnt have an in game vsync option. in the nvidia control panel there is a manage my 3d settings tab then inside that there is a global settings and another tab to customize settings specifically for that application. when i saw the lines my first thought was vsync since there wasnt one in the game so i went to set it specifically on the custom app settings but i didnt see an option for it. maybe i missed it or it is called something else.

cburke82, ill have to check again following that and see if i can see the vsync option.

i want to stay away from 3rd party software controlling my hardware, in my experience it tends to clash with the native software.

unfortunately i wont be at my computer again until tomorrow night cuz i have to work (work at gamestop :-D) so ill try to find the vsync again and force it on and also try another game that has vsync as an in game option and see if that changes it.
m
0
l
September 7, 2011 11:32:26 PM

as stated before, the answer is V-Synch. Enable it in any games you have the option too.
m
0
l
a b U Graphics card
September 8, 2011 6:02:48 AM

I have been using d3doverider included with rivatuner and it works for every game with no problems, I've used it with both nvidia and ati. It also enables triple buffering which you should enable when you use v-sync (apparently).

I have d3doverider mapped to my keyboard so you just launch it whenever you need it.

I recommend it if you can't find the setting in the Nvidia control panel, but I am sure it's there.
m
0
l
a c 104 U Graphics card
September 8, 2011 8:13:18 AM

It is there. It's not like i said thread optimizer, mistaking there. It's the one on the bottom, like cburke says. Vertical sync > force on.
m
0
l
September 15, 2011 3:16:18 AM

i suppose im writing this pretty late but i got everything worked out. the first game i was trying to play on this new computer was the force unleased 2 which i found out is a crappy port and runs at 30fps so with vsync off it tries to run at a ridiculously high framerate which makes the cut scenes look great but any fast motion in gameplay gets screen tearing cuz it exceeds the monitors capabilities. and if u turn vsync on it caps it at 60 which fixes the screen tearing in gameplay but it causes super choppy cutscenes and the sound cuts in and out and stutters. but then i popped in crysis 2 and everything was perfect so it was just that crappy game. thanks for ur help though
m
0
l
September 15, 2011 3:16:58 AM

Best answer selected by apexzer0.
m
0
l
!