Sign-in / Sign-up
Your question
Closed

Windows 7 slow to obtain DHCP ?

Tags:
  • Windows 7
Last response: in Windows 7
January 8, 2010 10:00:03 AM

I hope someone has an idea about a strange problem I'm having....

My PC is very fast, boot up is fast and when I first installed Windows 7, it used to obtain an IP address almost instantly.....now, after a few weeks use, the machine takes a lot longer to initiliase the networking, once it obtains the IP address, then everything else loads at quick speed and it runs fine.

I'm using an ASUS P5Q-E motherboard, with dual Marvell-Yukon Gigabit NICS (although only one is enabled) and a DLINK ADSL modem-router.

The router isn't the problem as other PCs connect to the network fine - And I'm sure it's not the network cards as I've downloaded and installed the latest ASUS approved version of the marvell-yukon WIN7 driver.

I've experimented with installing / uninstalling the NIC, letting it use standard WIN7 drivers instead, trying a couple of different versions of the NIC driver but all to no avail. It's really annoying, as my PC is very fast normally and this is the only thing causing a slow delay on boot (it takes about 20-30 seconds to initialise DHCP).

I have also tried using static IP instead, but this also made no difference..

If anybody has an idea about this problem, I would be really grateful for some help ?????

More about : windows slow obtain dhcp

a c 209 $ Windows 7
January 8, 2010 3:07:37 PM

I'd have a look at the System Event log and the log on the router (if it has one)...
Score
0
Anonymous
a b $ Windows 7
February 2, 2010 6:46:44 AM

I have exactly the same problem. My notebook is an ASUS W3V, and the DHCP is now slow with the ethernet card, with the wifi access, at home and at work. So I suppose it's a software problem, not hardware.
Score
0
Related resources

Best solution

February 2, 2010 10:32:35 PM

I've managed to sort my problem out, the solution if it helps others, is to go into SERVICES and set the following services to manual startup, rather than automatic startup. It is these services which are conflicting with the ethernet loading up.

APPLE BONJOUR - Set to manual, not automatic startup
KONTIKI - Set to manual (you will have kontiki if you run sky, 4OD or BBCi software), also disable automatic loading of kontiki when the PC boots up.

But the main culprit for me is Roxio Creator 2009 (Or any similar ROXIO product installed) Just disable all the ROXIO PNP services, and the ROXIO services which are set to automatic startup like diskwatch. These conflict with the way Windows 7 starts up various internal services. I'm told by Roxio this is a known fault which has been resolved in Version 2010 of Roxio Creator. I've personally also removed the automatic startup of things like diskwatch and media watch as I don't use them anyway but I think as long as you leave the services on manual, you can keep these in startup.

Instantly my problem went away and bootup speed was back to really fast again - the problem did come back, but only when I installed an update to my Blackberry desktop software (which of course, loads it's own version of Roxio Easy Media), so again I checked the services and lo-behold, it had re-enabled automatic startup of the Roxio PNP services again - which proved this solution was the correct one for me.

BONJOUR is also a guilty culprit for this problem, before I installed Roxio Creator, I disabled Bonjour and set to manual startup, this resolved the problem. (But then of course, I installed Roxio Creator 2009 and the problem came back again, same symptoms but different culprit).

I've been told by a friend who works at Microsoft that they are aware of this problem but are throwing it back to the software manufacturers, rather than writing a bug-fix to resolve the issues for us - How typical eh !

Hope this helps.....
Share
August 17, 2012 11:17:58 PM

Boy am I glad I saw this thread, I was going nuts with the same problem. I changed Bonjour service and Roxwatch to manual and bingo problem gone. I am not sure if it was just one or both but I do not need either to start auto so I am leaving well enough alone. Thanks!!!
Score
0
a c 610 $ Windows 7
August 18, 2012 12:56:43 AM

This topic has been closed by Area51reopened
Score
0
a c 610 $ Windows 7
August 18, 2012 12:58:54 AM

Best answer selected by Area51reopened.
Score
0