USB3 not working on Gigabyte X79-UP4

Hi Everyone,

I have a nice new Gigabyte X79-UP4 motherboard, and it is behaving for the most part, however the USB3 ports are not working.

Drivers for the port installed fine (from the disk that came with the motherboard) however it is not recognizing either USB3 or USB2 peripherals.

Device Manager reports that the USB3 ports are fine -





I did download the newest Fresco Logic drivers from Gigabyte and the package failed on install with the message below -



Even though the installer failed I was able to go through Device Manager & update the drivers, but unfortunately there has been no improvement in functionality - USB3 and USB2 still do not work.

I have tried several installer packages, from different locations, and all have failed!

Any help will be greatly appreciated.

Kind Regards,

Davo
1 answer Last reply
More about usb3 working gigabyte
  1. Hi Everyone,

    I have performed further testing and was surprised to find that my smartphone charges whilst connected to a USB3 port, both when the computer is turned on and when it is turned off. I thought that the Gigabyte On / Off Charge feature might be at fault so I uninstalled the driver related to this feature -



    After uninstalling the driver my computer is still unable to register that a USB peripheral is connected to any of the USB3 ports.

    Any help will be greatly appreciated.

    Kind Regards,

    Davo
Ask a new question

Read More

Motherboards Device Manager Drivers Gigabyte USB3